Bug 1609551 - glusterfs-resource-agents should not be built for el6
Summary: glusterfs-resource-agents should not be built for el6
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1609550
TreeView+ depends on / blocked
 
Reported: 2018-07-29 10:27 UTC by Niels de Vos
Modified: 2018-10-23 15:15 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1609550
Environment:
Last Closed: 2018-08-29 12:44:28 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2018-07-29 10:27:39 UTC
+++ This bug was initially created as a clone of Bug #1609550 +++

Description of problem:
glusterfs-resource-agents depends on glusterfs-server and this is not available on el6 with the current Gluster releases. It is not possible to install glusterfs-resource-agents on el6 without running into dependency problems.

Version-Release number of selected component (if applicable):
4.1.2-1.el6

How reproducible:
100%

Steps to Reproduce:
1. yum -y install centos-release-gluster
2. yum -y install glusterfs-resource-agents

Actual results:
Fails to install.

Expected results:
Should not be available at all.

Additional info:
Found this issue while playing with 'repoclosure' to get it integrated in the CentOS CI for validating the yum repositories.

Comment 1 Worker Ant 2018-07-29 14:03:38 UTC
REVIEW: https://review.gluster.org/20587 (rpm: do not build glusterfs-resource-agents on el6) posted (#1) for review on master by Niels de Vos

Comment 2 Worker Ant 2018-08-01 10:22:49 UTC
COMMIT: https://review.gluster.org/20587 committed in master by "Niels de Vos" <ndevos@redhat.com> with a commit message- rpm: do not build glusterfs-resource-agents on el6

glusterfs-resource-agents depends on glusterfs-server and this is not
available on el6 with the current Gluster releases. It is not possible
to install glusterfs-resource-agents on el6 without running into
dependency problems, so do not build the sub-packae at all.

Change-Id: Ibe08ad3a1b7882559b4e445603d0508b9282b755
Fixes: bz#1609551
Signed-off-by: Niels de Vos <ndevos@redhat.com>

Comment 3 Shyamsundar 2018-08-29 12:44:28 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.1.3, please open a new bug report.

glusterfs-4.1.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-August/000111.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 4 Shyamsundar 2018-10-23 15:15:49 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.