Bug 160979 - Missing BuildRequires dependency on libgcrypt-devel
Missing BuildRequires dependency on libgcrypt-devel
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: yelp (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-19 09:15 EDT by Andreas Thienemann
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-19 18:53:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Thienemann 2005-06-19 09:15:49 EDT
During a testbuild of yelp-2.6.4-2.src.rpm in mock, the rebuild process stops
with the following error:

gcc -DORBIT2=1 -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -I/usr/include/gconf/2
-I/usr/include/orbit-2.0 -I/usr/include/glib-2
.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gnome-vfs-2.0
-I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/bonobo-activat
ion-2.0 -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/X11R6/include
-I/usr/include/atk-1.0 -I/usr/include/pango-1
.0 -I/usr/include/freetype2 -I/usr/include/freetype2/config
-I/usr/include/libbonobo-2.0 -I/usr/include/libglade-2.0 -I/usr/in
clude/libxml2 -I/usr/include/libgnome-2.0 -I/usr/include/libgnomeui-2.0
-I/usr/include/libgnomecanvas-2.0 -I/usr/include/libar
t-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/gtkhtml-2.0 -O2 -g -pipe
-m64 -Wall -Wno-uninitialized -Wmissing-prototype
s -Wnested-externs -Wpointer-arith -Wno-sign-compare -o yelp GNOME_Yelp-stubs.o
GNOME_Yelp-skels.o GNOME_Yelp-common.o yelp-ba
se.o yelp-cache.o yelp-db-pager.o yelp-error.o yelp-history.o
yelp-html-gtkhtml2.o yelp-io-channel.o yelp-man-pager.o yelp-man
-parser.o yelp-pager.o yelp-toc-pager.o yelp-theme.o yelp-window.o yelp-uri.o
yelp-marshal-main.o yelp-main.o -Wl,--export-dyn
amic  -pthread -L/usr/X11R6/lib64 -lglade-2.0 -lgnomeui-2 -lSM -lICE
-lbonoboui-2 -lgnomecanvas-2 -lgnome-2 -lart_lgpl_2 -lpan
goft2-1.0 -lbonobo-2 -lgconf-2 -lgnomevfs-2 -lbonobo-activation -lORBit-2
-lgthread-2.0 -lgtkhtml-2 -lgtk-x11-2.0 -lgdk-x11-2.
0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0
-lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 /usr/lib64/li
bexslt.so -L/usr/lib64 /usr/lib64/libxslt.so -lgcrypt -lgpg-error
/usr/lib64/libxml2.so -lpthread -lm /usr/lib64/libpopt.so -l
z
/usr/bin/ld: cannot find -lgcrypt
collect2: ld returned 1 exit status
make[2]: *** [yelp] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/yelp-2.6.4/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/yelp-2.6.4'
make: *** [all-recursive-am] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.541 (%build)

Adding libgcrypt-devel to the BuildRequires list fixes this problem.
Comment 1 Ray Strode [halfline] 2005-06-19 18:53:27 EDT
Looks like this is already fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.