Bug 1609932 - [Regression] ACPI Error: Result stack is empty!
Summary: [Regression] ACPI Error: Result stack is empty!
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-30 21:05 UTC by James
Modified: 2018-08-09 16:51 UTC (History)
22 users (show)

Fixed In Version: kernel-4.17.12-200.fc28 kernel-4.17.12-100.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-08 16:10:17 UTC
Type: Bug


Attachments (Terms of Use)
Full dmesg in 4.17.11 (66.10 KB, text/plain)
2018-07-30 21:05 UTC, James
no flags Details

Description James 2018-07-30 21:05:43 UTC
Created attachment 1471643 [details]
Full dmesg in 4.17.11

Description of problem:
With kernel-4.17.11 I get a slew of ACPI errors at boot that weren't there in 4.17.10:

[    0.028419] ACPI Error: Result stack is empty! State=00000000f95979a7 (20180313/dswstate-65)
[    0.028430] ACPI Error: AE_AML_NO_RETURN_VALUE, Missing or null operand (20180313/dsutils-612)
[    0.028436] ACPI Error: AE_AML_NO_RETURN_VALUE, While creating Arg 0 (20180313/dsutils-727)
[    0.028491] ACPI Error: Result stack is empty! State=00000000f95979a7 (20180313/dswstate-65)
[    0.028497] ACPI Error: AE_AML_NO_RETURN_VALUE, Missing or null operand (20180313/dsutils-612)
[    0.028501] ACPI Error: AE_AML_NO_RETURN_VALUE, While creating Arg 0 (20180313/dsutils-727)
[    0.028508] ACPI Error: Result stack is empty! State=00000000f95979a7 (20180313/dswstate-65)
[    0.028513] ACPI Error: AE_AML_NO_RETURN_VALUE, Missing or null operand (20180313/dsutils-612)
[    0.028517] ACPI Error: AE_AML_NO_RETURN_VALUE, While creating Arg 0 (20180313/dsutils-727)
[    0.028653] ACPI Error: Result stack is empty! State=00000000f95979a7 (20180313/dswstate-65)
[    0.028658] ACPI Error: AE_AML_NO_RETURN_VALUE, Missing or null operand (20180313/dsutils-612)
[    0.028662] ACPI Error: AE_AML_NO_RETURN_VALUE, While creating Arg 0 (20180313/dsutils-727)
[    0.029103] ACPI Error: Result stack is empty! State=00000000f95979a7 (20180313/dswstate-65)
[    0.029109] ACPI Error: AE_AML_NO_RETURN_VALUE, Missing or null operand (20180313/dsutils-612)
[    0.029114] ACPI Error: AE_AML_NO_RETURN_VALUE, While creating Arg 0 (20180313/dsutils-727)
[    0.029276] ACPI Error: Result stack is empty! State=00000000f95979a7 (20180313/dswstate-65)
[    0.029282] ACPI Error: AE_AML_NO_RETURN_VALUE, Missing or null operand (20180313/dsutils-612)
[    0.029287] ACPI Error: AE_AML_NO_RETURN_VALUE, While creating Arg 0 (20180313/dsutils-727)
[    0.029924] ACPI Error: Result stack is empty! State=00000000f95979a7 (20180313/dswstate-65)
[    0.029930] ACPI Error: AE_AML_NO_RETURN_VALUE, Missing or null operand (20180313/dsutils-612)
[    0.029935] ACPI Error: AE_AML_NO_RETURN_VALUE, While creating Arg 0 (20180313/dsutils-727)
[    0.029941] ACPI Error: Result stack is empty! State=00000000f95979a7 (20180313/dswstate-65)
[    0.029947] ACPI Error: AE_AML_NO_RETURN_VALUE, Missing or null operand (20180313/dsutils-612)
[    0.029952] ACPI Error: AE_AML_NO_RETURN_VALUE, While creating Arg 0 (20180313/dsutils-727)
[    0.031717] ACPI Error: Result stack is empty! State=00000000f95979a7 (20180313/dswstate-65)
[    0.031725] ACPI Error: AE_AML_NO_RETURN_VALUE, Missing or null operand (20180313/dsutils-612)
[    0.031730] ACPI Error: AE_AML_NO_RETURN_VALUE, While creating Arg 0 (20180313/dsutils-727)
[    0.031738] ACPI Error: Result stack is empty! State=00000000f95979a7 (20180313/dswstate-65)
[    0.031743] ACPI Error: AE_AML_NO_RETURN_VALUE, Missing or null operand (20180313/dsutils-612)
[    0.031748] ACPI Error: AE_AML_NO_RETURN_VALUE, While creating Arg 0 (20180313/dsutils-727)

Full dmesg attached.

Comment 1 James 2018-07-30 21:06:39 UTC
Seems it's known and patched - https://lkml.org/lkml/2018/7/28/151

Comment 2 Ozkan Sezer 2018-08-02 09:04:01 UTC
Fix went in 4.17.12-stable which should be out soon
https://lkml.org/lkml/2018/8/1/811

Comment 3 Fedora Update System 2018-08-03 20:38:02 UTC
kernel-headers-4.17.12-1.fc28 kernel-tools-4.17.12-200.fc28 kernel-4.17.12-200.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ca0e10fc6e

Comment 4 Fedora Update System 2018-08-03 20:42:07 UTC
kernel-headers-4.17.12-1.fc27 kernel-tools-4.17.12-100.fc27 kernel-4.17.12-100.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-2f6df9abfb

Comment 5 Alessio 2018-08-04 07:02:21 UTC
(In reply to Ozkan Sezer from comment #2)
> Fix went in 4.17.12-stable which should be out soon
> https://lkml.org/lkml/2018/8/1/811

Ok. These messages are gone with this update.

Comment 6 Fedora Update System 2018-08-04 20:31:34 UTC
kernel-4.17.12-100.fc27, kernel-headers-4.17.12-1.fc27, kernel-tools-4.17.12-100.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2f6df9abfb

Comment 7 Fedora Update System 2018-08-04 22:36:35 UTC
kernel-4.17.12-200.fc28, kernel-headers-4.17.12-1.fc28, kernel-tools-4.17.12-200.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ca0e10fc6e

Comment 8 HaskellCurry 2018-08-08 01:43:49 UTC
Still present in .12. I can confirm that rolling back to .9 fixes it.

Comment 9 HaskellCurry 2018-08-08 01:45:43 UTC
(In reply to HaskellCurry from comment #8)
> Still present in .12. I can confirm that rolling back to .9 fixes it.


Apologies, seems to be fixed.

Comment 10 Fedora Update System 2018-08-08 16:10:17 UTC
kernel-4.17.12-200.fc28, kernel-headers-4.17.12-1.fc28, kernel-tools-4.17.12-200.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2018-08-09 16:51:52 UTC
kernel-4.17.12-100.fc27, kernel-headers-4.17.12-1.fc27, kernel-tools-4.17.12-100.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.