Bug 1610151 (CVE-2018-5815) - CVE-2018-5815 LibRaw: Integer overflow in internal/dcraw_common.cpp:parse_qt() allows for denial of service
Summary: CVE-2018-5815 LibRaw: Integer overflow in internal/dcraw_common.cpp:parse_qt(...
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2018-5815
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20180722,repor...
Depends On: 1610161 1610152 1610153 1610154
Blocks: 1610155
TreeView+ depends on / blocked
 
Reported: 2018-07-31 04:51 UTC by Sam Fowler
Modified: 2019-06-08 23:04 UTC (History)
7 users (show)

Fixed In Version: LibRaw 0.18.12
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-31 14:41:46 UTC


Attachments (Terms of Use)

Description Sam Fowler 2018-07-31 04:51:13 UTC
LibRaw versions prior to 0.18.12 are vulnerable to an integer overflow in the internal/dcraw_common.cpp:parse_qt() function. An attacker could exploit this to cause an infinite loop via a specially crafted Apple QuickTime file.


Reference:

http://seclists.org/bugtraq/2018/Jul/58

Comment 1 Sam Fowler 2018-07-31 04:51:47 UTC
Created LibRaw tracking bugs for this issue:

Affects: fedora-all [bug 1610152]


Created mingw-LibRaw tracking bugs for this issue:

Affects: fedora-all [bug 1610153]

Comment 3 Sam Fowler 2018-07-31 04:59:30 UTC
Created LibRaw tracking bugs for this issue:

Affects: epel-6 [bug 1610161]

Comment 4 Stefan Cornelius 2018-07-31 12:39:37 UTC
This looks like the patch:
https://github.com/LibRaw/LibRaw/commit/4554e24ce24beaef5d0ef48372801cfd91039076

Comment 5 Stefan Cornelius 2018-07-31 12:56:16 UTC
Introduced via:
https://github.com/LibRaw/LibRaw/commit/05f1585e8f130b958e3a921d70acfd9656d45c35

This is not in RHEL7.

Comment 6 Stefan Cornelius 2018-07-31 12:56:23 UTC
Statement:

This issue did not affect the versions of LibRaw as shipped with Red Hat Enterprise Linux 7.

Comment 7 Debarshi Ray 2018-09-27 14:10:06 UTC
This was fixed in LibRaw 0.19.0-Beta6 and 0.18.12


Note You need to log in before you can comment on or make changes to this bug.