Bug 161028 - lam should be built with -fPIC on x86_64
lam should be built with -fPIC on x86_64
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lam (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-19 21:40 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 7.1.1-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 04:33:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-06-19 21:40:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.6 (KHTML, like Gecko) Safari/412.2

Description of problem:
Since only static libs are being built for the lam package, on those architectures like x86_64 and ppc_64
which require all code linked into shared libaries to be built with -fPIC, this package should be built with 
that flag. Currently x86_64 will not allow libmpi.a to be linked into a shared library because libmpi.a is 
built without -fPIC,

Version-Release number of selected component (if applicable):
lam-7.1.1-3

How reproducible:
Always

Steps to Reproduce:
1. Try to link libmpi.a into a shared library.


Additional info:
Comment 1 Jason Vas Dias 2005-07-12 14:34:57 EDT
This bug is now fixed with lam-7.1.1-6, released as FC3 and FC4 updates today.

Note You need to log in before you can comment on or make changes to this bug.