Bug 161029 - No volume control elements and/or devices found (Pop Up)
No volume control elements and/or devices found (Pop Up)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-volume-manager (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-19 21:50 EDT by Kevin Maximo
Modified: 2013-03-05 22:43 EST (History)
8 users (show)

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-22 16:34:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Maximo 2005-06-19 21:50:37 EDT
Description of problem:
No volume control elements and/or devices found

Version-Release number of selected component (if applicable):


How reproducible:
Upon every log in and log out

Steps to Reproduce:
1. Log in
2. Log out
3.
  
Actual results: 
Just reports a pop up every time.  

Expected results:
Just want to stop pop up

Additional info:
No sound card in machine or one that is supported - do not need sound just 
stop the error message.
Comment 1 Bob Chiodini 2005-06-23 07:07:54 EDT
This is a problem in FC3 also, even with a supported sound card.   Oddly,
gkrellm and the gnome volume control master control (left-click on the speaker
icon) works correctly.  Alsamixer also works correctly.

Restarting the volume control applet causes the master control to disappear too.
Comment 2 Robert Nichols 2005-06-23 18:39:24 EDT
The problem is an out-of-date timestamp on
/var/cache/gstreamer-0.8/registry-i386.xml .
Just run /usr/bin/gst-register (as root) to fix it.  The strange thing is that it's
apparently st_ctime that is being checked, not st_mtime.  When I tried restoring
to a
spare partition from backup tapes in an effort to see when the problem was
introduced,
gnome-volume-control worked just fine even though all the files were identical
except for
the st_ctime stamps.  I consider that a bug.  What's important is when the
contents of
the file changed, not when the file might have been restored from some old backup.
All that was actually needed to make the volume control work again was
"touch -ac /var/log/gstreamer-0.8/registry-i386.xml", which has the side effect of
updating the ctime.
Comment 3 Kevin Maximo 2005-06-23 21:33:09 EDT
That did not cure it for me...
Comment 4 Bob Chiodini 2005-06-24 06:51:25 EDT
Running /usr/bin/gst-register restored the controls in the applet here.  I had
to restart the applet for the "master" (left-click) control to operate.
Comment 5 Kevin Maximo 2005-06-24 20:53:24 EDT
It does nothing for me.  I don't have /usr/bin/gst-register.  I have
/usr/bin/gst-register-0.8 and I've run that but still no go.  I don't want any
sound item because I don't have a sound card that is compatible with anything. 
It's an ancient card.  Others are getting this same error without having a card
what so ever.
Comment 6 Kevin Maximo 2005-06-29 17:58:42 EDT
Just wish you could disable Sound altogether or even the hardware - to eliminate
this message.  Am I missing something somewhere as to why I do not have the file
you mentioned to run but one similar with the -0.8 on the end???
Comment 7 Robert Nichols 2005-06-29 19:33:08 EDT
File /usr/bin/gst-register-0.8 is provided by the gstreamer package.
File /usr/bin/gst-register is provided by gstreamer-tools.  The two files
are identical.
Comment 8 Kevin Maximo 2005-06-29 19:42:31 EDT
Ok just wanted to make sure I ran the right item.  As I mentioned I did that 
but it did not resolve the issue.  That same pop up message still happens upon 
every logon and logoff.  As I said I shut off what I thought was all sound 
options I could find but it still didn't stop it from popping up everytime...
Comment 9 John (J5) Palmieri 2005-06-29 20:02:24 EDT
If you don't have the hardware you can always remove the sound applet from the
panel and that should suppress the dialogs.
Comment 10 Kevin Maximo 2005-06-30 19:35:59 EDT
How do you go about doing that.  I don't have any sound items on the panels.  
As I said I went through every preference I could find.  I'm only a Linux 
novice but an Expert with computers and Windows.  I've unchecked every 
possible thing I could dig up that had to do with sound.  The pop up is still 
there.  I have my linux box on a KVM switch and when I'm not even doing 
anything on that system but when I switch over to it I'll see two pop ups one 
about hardware and the other the one that I wrote this bug about.
Comment 11 Jim Caley 2005-07-01 14:44:29 EDT
I'd like to second Kevin's comments above.  I freshly installed FC4 and have
done no other work on it since, so I suppose a workaround would be to reinstall
-- taking care to leave off any sound-related components -- but would rather
just disable whatever it is that's causing this message.

My box has no sound card, and I get the same pop-up he does upon login using Gnome.

I have no sound applet in the panel.

I also tried running /usr/bin/gst-register-0.8 with no luck.

Neither esd or artsd is running.
Comment 12 John (J5) Palmieri 2005-07-01 15:38:34 EDT
It is most likely the applet starting up and exiting while throwing up the
dialog.  As a temporary solution try logging out and click the save current
setup checkbox on the logout dialog.  After doing that log back in to see if you
get the error.  I have to investigate this more and have it not throw up the
error if you don't have sound hardware.
Comment 13 Jim Caley 2005-07-01 16:13:24 EDT
Yes, I tried checking the Save Current Setup checkbox (both for root and another
user) when logging out but it didn't help; the pop-up still showed up on the
next login.

As a matter of fact -- and I don't know if this may be helpful or not -- as I
tried your suggestion of logging in, closing the "No volume control..." pop-up,
and then logging out with Save Current Setup checked, I had a warning come up
about the user session lasting less than 10 seconds (no problem or surprise
there), but *then* the "No volume control..." pop-up came up again -- presumably
because the warning pop-up triggered a sound event.

So my point is that whatever is generating the sound events apparently didn't go
away after the first time I closed the "No volume control..." pop-up.
Comment 14 Kevin Maximo 2005-07-01 17:25:22 EDT
No that won't do it either, I actually do that after every single log off no 
matter what, always did that not know exactly what it was doing. As I said a 
linux novice. The error comes up twice on log on and once on exit.  So during 
log in there must be two sound events or one for trying to load the hardware 
and one for the sound event it is trying to play. Both are the exact same 
error though.  It's really no big deal but I think it does do something to 
performance when it happens and it's very annoying... LOL.
Comment 15 Ed Davis 2005-07-08 11:32:43 EDT
My situation is a little different.  I've done a fresh install of FC4
(everything install).  My system does have a soundcard.  Sound works fine.

I do not see the pop up "No volume control elemets and/or devices found" when I
log in as root.  When I log in a root the gnome volume controls work properly
and sound works properly.

The same is true if I log in as the user account created during FC4 installation.

I have created a few more user accounts and all of these additional accounts get
the pop up "No volume control elemets and/or devices found" upon log in.  The
sound works but the only way to control the volume is by using the knob on the
speakers.  The volume icon is not available for these additional accounts.

Since I don't have this problem with root or with the first account I'm guessing
this is a file permission thing.  If I stumble upon a solution I'll post.
Comment 16 John (J5) Palmieri 2005-07-08 12:06:21 EDT
It does sound like a permissions problem.  Can you give me the output of:
ls -l /dev/dsp
ls -l /dev/audio
ls -l /dev/mixer

Thanks
Comment 17 Ed Davis 2005-07-08 13:46:36 EDT
There is something strange going on with the permissions on those files.  I
changed them so that the problem goes away.  Then on the next reboot and log in
those file permissions are all messed up again and the problem comes back.

Here are some file permissions from /dev

crw-------  1 nub  root    14,   3 Jul  8 05:01 dsp
crw-------  1 nub  root    14,   4 Jul  8 05:01 audio
crw-------  1 nub  root    14,   0 Jul  8 05:01 mixer

If I chown root:root and chmod 666 it does not hold.  It changes after reboot
and log in.

My problem is different than the others on this list.  Everything works fine for
 root or the first user that logs in after a reboot.  The second, third, etc
users to log in get the pop up window.

At first I thought it was everything worked fine for the user created during the
FC4 install.  That's not quite correct.  Everything works fine for the first
user to log in after a reboot.
Comment 18 Ed Davis 2005-07-08 14:22:05 EDT
I discovered one more thing.  Everything is fine if the first user does Desktop
-> Log Out before the second user comes to the system and logs in.

To duplicate the problem log in a second user without logging out the first user.

Applications -> System Tools -> New Login

I'm not too worried about this bug.  The workaround is to log out the first user
from the console before logging in the second user.  

Most of the time this is no big deal, it just means the first user needs to
close applications and save files before the second user can log onto the
console and have volume controls.  This is usually a minor inconvenience.
Comment 19 John (J5) Palmieri 2005-07-08 14:28:42 EDT
Ah, ok.  So that is expect behavoir actually (well the applet shouldn't screem
at you).  When you log in all the permissions are switched to you and you grab
the console lock.  Anyone logging in after you can not grab the lock and can not
steal permissions.  If you log out you release the console lock and the next
person is free to grab it and change permissions.  In the future we want to
change this but for now that is how it works.
Comment 20 Kevin Maximo 2005-07-11 09:54:35 EDT
Ok, I fixed my issue with this item.  I Deleted all of my PANELS and simply
re-created new PANELS.

What I'm gathering is since the Volume Control is blowing up it does not show on
the main PANEL on top of screen but that was the one that should of had the
Volume Control on it.  

By Deleting the MAIN PANEL - the one that had all the icons on it - mine was on
top of screen with applications, desktop, log in and out, and the task bar area
with the RHN icon.

I Deleted and rebuilt a NEW one and the error is now gone.  This does not
resolve the reason why it kept blowing up but it does stop the errors from
popping up.
Comment 21 Tom Wood 2005-07-11 14:53:34 EDT
I get this same error on machines with no sound hardware.  gnome 2.10 seems to
expect to find sound hardware by default.  And, with no decent way to edit the
<blood-curdling scream>gnome registry<blood-curdling scream>, there seems to be
no way except to delete the entire default panel as comment #20 stated.  The RPM
dependencies don't allow for reasonable removal of the multimedia packages
responsible for this either.

What's needed is a real registry editor for gnome, not gconftool-2, and/or a
non-multimedia gnome core without all the unnecessary sound dependencies.  
Comment 22 Kevin Maximo 2005-07-11 16:25:55 EDT
I just don't understand why I never had this error message pop up until I went
to FC4, The Sound Icon or Volume Manager would always appear on all the previous
releases from FC1 to FC3 on the panel and would not report error messages or
blow up for that matter - but I am happy I ridded myself of those darn pop up
messages - as I said I think it reduced performance also when this occurred as
if in some kind of loop???
Comment 23 John (J5) Palmieri 2005-07-11 16:30:31 EDT
Most likely a bug in the upstream sources was introduced in GNOME 2.10.  It
could also be an alsa/dmix bug.  I am still looking into the root causes.
Comment 24 Jack Tanner 2005-09-14 10:56:21 EDT
J5, any updates on this? Last comment is two months old.

I also see this bug when connecting to an FC4 bugs via NX (set up per
instructions at http://fedoranews.org/contributors/rick_stout/freenx/). I'm not
forwarding audio, so the error message is understandable, but still annoying. A
nicer UI would be something like the volume control icon in the panel getting a
red slash through it.
Comment 25 John (J5) Palmieri 2005-09-14 11:26:14 EDT
This is fixed in Rawhide.  I will look into fixing it for fc4.
Comment 26 David Childers 2005-10-23 01:12:55 EDT
Hi there.  I am using FC3 with an Ensoniq sound card in a 700Mhz PIII.  I have
very similar symptoms.  One thing that might be a clue is that when I open
volume control preferences I see no audio channels available to control.  I do
get system sounds and I can hear streaming audio but when I try to listen to a
CD there's no sound.  The volume control is at minimum and when I try to move
the slider up with my mouse it instantly snaps back to minimum with no change in
sound level.  Hope this helps.

Thanks!

/David C.
Comment 27 Jerry 2006-01-19 22:02:18 EST
I just got this error after an SELINUX relabel.  On FC4.  I have not had a wink
of a problem with thi sbefore and i always use the volume control on the panel.
 Nw I can't get the panel volume control.  Also gives the error when I try to
add volume control to the panel and I tried the gst-register with no effect.

SELINUX problem?
Comment 28 John (J5) Palmieri 2006-01-20 11:12:26 EST
if you /usr/sbin/setenforce 0 and then try to add the applet does it work?
Comment 29 Christian Iseli 2007-01-22 05:04:15 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.

Note You need to log in before you can comment on or make changes to this bug.