Bug 161037 - chroot segv on rescue cd
chroot segv on rescue cd
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: busybox (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-20 01:17 EDT by Daryll
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-21 09:56:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daryll 2005-06-20 01:17:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
I booted the FC4 rescue CD on a RH EL WS 3.0 system with the hopes of fixing a corrupted boot loader. The rescue disc boots fine, but when I tried to chroot /mnt/sysimage it segfaulted. I also tried chroot /mnt/sysimage /bin/ls and that segfaulted as well.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot the rescue cd
2. chroot /mnt/sysimage
3.
  

Actual Results:  
segfault and no chroot

Expected Results:  New shell chroot'ed

Additional info:
Comment 1 Daryll 2005-06-21 10:58:16 EDT
I suspect the issue is mixing the two OS versions. Did you test the mismatched
versions?

The reason I think that might be the problem, is that I just updated my FC3
system to the packages in updates-testing and now if I attempt to boot any of my
old kernels (2.6.11-1.27 for example) it reports a core dump very early in the
init process. If I boot the kernel 2.6.11-1.35 (which is also in updates
testing) then everything works fine.

We needed a rescue disc from FC4 because it had SATA drivers that aren't in EL3.
Maybe this isn't supposed to work?
Comment 2 Ivana Varekova 2005-06-22 02:43:19 EDT
I test fc4 rescue CD on a RHEL3 system and it works fine. Probably there is some
mistake on the system you want to chroot which causes this error. 

Note You need to log in before you can comment on or make changes to this bug.