Bug 1610378 - Cannot upgrade Server Edition from F28 to F29 due to removed rolekit package
Summary: Cannot upgrade Server Edition from F28 to F29 due to removed rolekit package
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rolekit
Version: 28
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F29BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2018-07-31 13:53 UTC by Stephen Gallagher
Modified: 2018-07-31 15:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-31 14:51:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1610422 None None None Never

Internal Links: 1610422

Description Stephen Gallagher 2018-07-31 13:53:08 UTC
Description of problem:
In Fedora 28, the fedora-release package pulled in the rolekit package, which has been retired and blocked from F29, partly because it was no longer compatible with Python 3.7. Because the F28 version is incompatible with Python 3.7 in Fedora 29, it needs to be removed from systems for a successful upgrade.

Version-Release number of selected component (if applicable):
rolekit-0.5.2-2.fc28

How reproducible:
Every time

Steps to Reproduce:
1. Install Fedora 28 Server Edition
2. Update to the latest versions using `dnf update`
3. Run `dnf system-upgrade --releasever=29 download`

Actual results:
 Problem: package rolekit-0.5.2-2.fc28.noarch requires python(abi) = 3.6, but none of the providers can be installed
  - python3-3.6.6-1.fc28.x86_64 does not belong to a distupgrade repository
  - problem with installed package rolekit-0.5.2-2.fc28.noarch


Expected results:
Upgrade completes successfully.

Additional info:
rolekit needs to be added to fedora-obsolete-packages

Comment 1 Fedora Blocker Bugs Application 2018-07-31 13:54:00 UTC
Proposed as a Blocker for 29-beta by Fedora user sgallagh using the blocker tracking app because:

 "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from a fully updated, clean default installation of each of the last two stable Fedora releases with that package set installed."

Comment 2 Stephen Gallagher 2018-07-31 14:03:40 UTC
Submitted change for fedora-obsolete-packages as https://src.fedoraproject.org/rpms/fedora-obsolete-packages/pull-request/6

Comment 3 Peter Robinson 2018-07-31 14:51:40 UTC
Built in rawhide, will be in the next compose (likely tomorrow)


Note You need to log in before you can comment on or make changes to this bug.