Bug 1610437 - Builds fail with Generic Build failure when they are killed because resources constraints
Summary: Builds fail with Generic Build failure when they are killed because resources...
Keywords:
Status: CLOSED DUPLICATE of bug 1596440
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Ben Parees
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-31 15:18 UTC by Elyézer Rezende
Modified: 2018-07-31 15:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-31 15:21:08 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Elyézer Rezende 2018-07-31 15:18:23 UTC
Description of problem:

When building a Docker image that uses more than the resources limit (for example memory) the build fails with Generic Build failure with nothing in the logs. The error message mentions to check the logs but there is nothing telling that the build was actually killed because resource constraints.

It would be much better if OpenShift told what exactly had happened.  


Version-Release number of selected component (if applicable):

OpenShift Master: v3.9.31
Kubernetes Master: v1.9.1+a0ce1bc657
OpenShift Web Console: v3.9.31

How reproducible:

Always


Steps to Reproduce:
1. Create a project and set a low resources limit
2. Create a build config to build a docker image which requires more memory than the amount allowed by the resources limit.
3. Try to build and watch the Web UI and the build logs. The build will have the error state and no useful information will be given on the logs.

For example try to build https://gitlab.com/cloudigrade/frontigrade.git with the following limitrange:

$ oc describe limitrange
Name:       resource-limits
Namespace:  cloudigrade-review
Type        Resource  Min   Max  Default Request  Default Limit  Max Limit/Request Ratio
----        --------  ---   ---  ---------------  -------------  -----------------------
Pod         memory    50Mi  2Gi  -                -              -
Pod         cpu       100m  1    -                -              -
Container   cpu       -     -    200m             300m           10
Container   memory    -     -    100Mi            200Mi          -


Actual results:

The build fails with Generic Build failure and no useful information is provided even though was OpenShift that actually killed it.

Expected results:

The build fails with a more specific failure and stating that it was killed by OpenShift because resource constraints.


Additional info:

Comment 1 Ben Parees 2018-07-31 15:21:08 UTC

*** This bug has been marked as a duplicate of bug 1596440 ***


Note You need to log in before you can comment on or make changes to this bug.