Bug 161047 - White screen during install on Toshiba Satellite Pro 600 (Trident videocard)
White screen during install on Toshiba Satellite Pro 600 (Trident videocard)
Status: CLOSED DUPLICATE of bug 161242
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-20 04:14 EDT by Ton Hoogstraten
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-23 13:28:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ton Hoogstraten 2005-06-20 04:14:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
When starting up the graphical installer on a FC4 installation on a Toshiba Satellite Pro 6000 the screen turns white and you see the mouse X cursor briefly. The cursor dissapears and you are left with a blank screen. The system is not hangign you can switch to the text consoles and back.

If you install in text mode you are able to fully install FC4. When X windows starts you get the same white screen. Again the system is not hanging. If you switch to text mode you can work fine.

The video card detected by FC4 is Trident CyberBlade (Generic) the monitor type detected is unknown.

The installation with FC3 works perfectly in graphical mode.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try installing FC4 on a Toshiba Satellite Pro 6000 in graphic mode.
2.
3.
  

Actual Results:  Mouse X cursos is displayed briefly on a white background. Mouse dissapears and the screen remains white.

Expected Results:  The welcome screen should be displayed to start the GUI installation.

Additional info:

FC3 also reports the videocard being a Trident CyberBlade (generic) on monitor type Unknown Monitor. However the GUI install starts normally.
Comment 1 Jeremy Katz 2005-06-20 14:12:51 EDT
Does booting with 'linux nofb' help?
Comment 2 Ton Hoogstraten 2005-06-21 06:13:51 EDT
When trying to install with 'linux nofb' you get the same result. A white screen
instead of the welcome screen.

Thanks,

Ton
Comment 3 Ton Hoogstraten 2005-06-21 07:08:59 EDT
the 'nofb' also results in the console modes when switching with ctrl-alt-f1
etc. to be unreabable.

Regards,

Ton
Comment 4 Jeremy Katz 2005-06-21 13:31:10 EDT
If you do a text mode install, does X work after installation?
Comment 5 Ton Hoogstraten 2005-06-22 03:12:33 EDT
No after installation the startup of X gives the same result.
Comment 6 Doug Townes 2005-06-22 10:09:33 EDT
I get exactly the same results when installing on a Compaq Deskpro 7100 if I 
attempt to install in graphic mode.  I do not ever actually getting even 
briefly a cursor.  
The text mode install allows me to get further but eventually crashes (will 
check for other bugs related to that).
Comment 7 Doug Townes 2005-06-22 10:11:14 EDT
Sorry, should have mentioned that my video card is detected as the same 
(Trident CyberBlade) and the monitor shows as unknown also.
Comment 8 Dlamija Tua 2005-06-22 22:56:23 EDT
I have the same problem.

Model: Toshiba Portege 3500
Video Card (detected) : Trident CyberBlade (generic)
Monitor (detected) : TOS5082

Problem: Display goes blank with graphical installation.

Installation with text mode: OK, but display still goes blank when try to start X
Comment 9 Dlamija Tua 2005-06-22 23:36:01 EDT
It's works now....
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161242

replace /usr/X11R6/lib/modules/libvgahw.a (XORG package) with file from FC3...
you can get is from ftp://people.redhat.com/mharris/libvgahw.a

Thank to Harris
Comment 10 Mike A. Harris 2005-06-23 13:28:45 EDT

*** This bug has been marked as a duplicate of 161242 ***
Comment 11 ishwar 2005-08-12 14:29:40 EDT
hi i had the same problem with a portege 2000 and the libvgahw solution works
fine.
Comment 12 Mukesh 2005-09-05 02:58:19 EDT
Hi, all of you

Trident CyberBlade integrated AGP solution for FC4 might work for others.
After installation of FC4 in text mode.

If you can login in text mode then open xorg.conf as a root. Find 
section 'Device'
Change Driver "vesa"
Vender "Unknown"  ########## OR

Insert first installation FC4 DVD/CD type linux rescue enter
you will in shell prompt follow above procedure. reboot and enjoy.


If you steel face problem mail me. mlmukesh@yahoo.com 
Or you have other solution for above agp cards please send me.

mukesh  

Note You need to log in before you can comment on or make changes to this bug.