Bug 1610536 - FreeIPA server deployment on Rawhide fails (after #1607635 fix) with failure to access 'https://ipa001.domain.local/ipa/json' during client install phase, due to broken import in /usr/share/ipa/wsgi.py
Summary: FreeIPA server deployment on Rawhide fails (after #1607635 fix) with failure ...
Status: CLOSED DUPLICATE of bug 1609491
Alias: None
Product: Fedora
Classification: Fedora
Component: freeipa   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: IPA Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F29BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2018-07-31 21:10 UTC by Adam Williamson
Modified: 2018-08-01 00:33 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-07-31 23:14:38 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Williamson 2018-07-31 21:10:24 UTC
When testing FreeIPA server deployment with the fixed softhsm for https://bugzilla.redhat.com/show_bug.cgi?id=1607635 , deployment now fails later, during the ipa-client-install phase, with this error:

2018-07-31T19:53:16Z DEBUG The ipa-client-install command failed, exception: NetworkError: cannot connect to 'https://ipa001.domain.local/ipa/json': Internal Server Error
2018-07-31T19:53:16Z ERROR cannot connect to 'https://ipa001.domain.local/ipa/json': Internal Server Error

/var/log/httpd/error_log shows us the underlying problem:

[Tue Jul 31 15:53:12.797512 2018] [wsgi:error] [pid 437:tid 139730941749504] mod_wsgi (pid=437): Failed to exec Python script file '/usr/share/ipa/wsgi.py'.
[Tue Jul 31 15:53:12.797574 2018] [wsgi:error] [pid 437:tid 139730941749504] mod_wsgi (pid=437): Exception occurred processing WSGI script '/usr/share/ipa/wsgi.py'.
[Tue Jul 31 15:53:12.797600 2018] [wsgi:error] [pid 437:tid 139730941749504] Traceback (most recent call last):
[Tue Jul 31 15:53:12.797626 2018] [wsgi:error] [pid 437:tid 139730941749504]   File "/usr/share/ipa/wsgi.py", line 43, in <module>
[Tue Jul 31 15:53:12.797744 2018] [wsgi:error] [pid 437:tid 139730941749504]     from ipaplatform.paths import paths
[Tue Jul 31 15:53:12.797774 2018] [wsgi:error] [pid 437:tid 139730941749504] ImportError: No module named ipaplatform.paths

As for all FreeIPA server deployment failures, this is a clear Beta blocker, per https://fedoraproject.org/wiki/Basic_Release_Criteria#FreeIPA_server_requirements , "It must be possible to configure a Fedora Server system installed according to the above criteria as a FreeIPA domain controller, using the official deployment tools provided in the distribution FreeIPA packages."

Comment 1 Adam Williamson 2018-07-31 23:14:38 UTC

*** This bug has been marked as a duplicate of bug 1609491 ***


Note You need to log in before you can comment on or make changes to this bug.