Bug 16106 - XDMCP broken in gdm-2.0beta2, needs beta4 version
XDMCP broken in gdm-2.0beta2, needs beta4 version
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
Winston gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-13 15:02 EDT by John Cagle
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-13 21:44:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Cagle 2000-08-13 15:02:44 EDT
The XDMCP implementation in "gdm-2.0beta2-35" is broken.  It will not manage remote
X Terminals even if "Enable=1" in the [xdmcp] section of /etc/X11/gdm/gdm.conf.

The beta4 version works for me.  Here's a note from it's ChangeLog:

1999-09-30   <mkp@mkp.net>

     * daemon/xdmcp.c (gdm_xdmcp_handle_query): Get XDMCP running again.

Please update this package to the beta4 version.  I downloaded mine from:

   ftp://spidermonkey.helixcode.com/pub/helix/distributions/RedHat-6/gdm-2.0beta4-0_helix_6.i386.rpm
Comment 1 Glen Foster 2000-08-13 16:18:32 EDT
This defect is considered MUST-FIX for Winston Gold-release
Comment 2 Owen Taylor 2000-08-13 21:44:10 EDT
I'm putting a new RPM into 7.0test that fixes this in testing.
I've asked Havoc to review the change, since it is a fix to
a fix of his, but I think it is correct.

(The Red Hat 2.0beta2 is a essentially a separate branch which
is considerably better than the stock 2.0beta4. Merging all
our patches to the stock 2.0beta4 would be impractical, and,
in any case, the maintainer has abandoned gdm2 and is now
working on gdm3.)
Comment 3 Havoc Pennington 2000-08-13 22:15:39 EDT
Owen's fix looks good to me.
Comment 4 John Cagle 2000-08-14 10:50:50 EDT
If you send me the fix, I'll be glad to test it.
Comment 5 John Cagle 2000-08-20 10:49:14 EDT
Tested gdm2.0-beta2-37 from Havoc.  Works for me!
Thanks!

Note You need to log in before you can comment on or make changes to this bug.