Bug 1610605 - rbd json format of 7.6 is incompatible with 7.5
Summary: rbd json format of 7.6 is incompatible with 7.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.6
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Virtualization Maintenance
QA Contact: CongLi
URL:
Whiteboard:
Depends On:
Blocks: 1635585
TreeView+ depends on / blocked
 
Reported: 2018-08-01 03:35 UTC by Longxiang Lyu
Modified: 2018-11-01 11:15 UTC (History)
6 users (show)

Fixed In Version: qemu-kvm-rhev-2.12.0-16.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1635585 (view as bug list)
Environment:
Last Closed: 2018-11-01 11:13:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3443 None None None 2018-11-01 11:15:34 UTC

Description Longxiang Lyu 2018-08-01 03:35:17 UTC
Description of problem:
rbd json format of 7.6 is incompatible with 7.3

Version-Release number of selected component (if applicable):
qemu-img-rhev-2.6.0-28.el7_3.14.x86_64
qemu-img-rhev-2.12.0-8.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. create a snapshot based on image on rbd with old-fashioned json format

# qemu-img --version
qemu-img version 2.6.0 (qemu-kvm-rhev-2.6.0-28.el7_3.14), Copyright (c) 2004-2008 Fabrice Bellard

# qemu-img create -f qcow2 -b 'json:{"file.driver":"rbd","file.filename":"rbd:rbd/test.raw"}' test.qcow2
Formatting 'test.qcow2', fmt=qcow2 size=21474836480 backing_file=json:{"file.driver":"rbd",,"file.filename":"rbd:rbd/test.raw"} encryption=off cluster_size=65536 lazy_refcounts=off refcount_bits=16

2. update to latest qemu-kvm and check the snapshot.
# qemu-img --version
qemu-img version 2.12.0 (qemu-kvm-rhev-2.12.0-8.el7)

# qemu-img check test.qcow2
qemu-img: Could not open 'test.qcow2': Could not open backing file: Parameter 'pool' is missing


Actual results:
fail to check snapshot created with old-fashioned json.

Expected results:
should be back compatible.

Additional info:

Comment 4 Jeff Cody 2018-08-15 17:22:38 UTC
My fear is this means is we may need to add additional support in block/rbd.c for explicitly parsing the older key/value pair format, e.g.: rbd:rbd/testimg.raw:mon_host=192.168.15.180

Comment 7 Jeff Cody 2018-09-11 05:17:47 UTC
Patch series posted upstream.  Unsure if this will become the final solution; it is a bit hacky, but I'm not sure there are any great options to fix it.

Comment 11 Miroslav Rezanina 2018-09-17 08:53:22 UTC
Fix included in qemu-kvm-rhev-2.12.0-16.el7

Comment 13 CongLi 2018-09-17 11:02:16 UTC
Steps as comment 0.

Reproduced this issue on qemu-kvm-rhev-2.12.0-15.el7.x86_64:
# qemu-img check test.qcow2
qemu-img: Could not open '/home/test.qcow2': Could not open backing file: Parameter 'pool' is missing

Verified this bug on qemu-kvm-rhev-2.12.0-16.el7.x86_64:
# qemu-img check test.qcow2
qemu-img: RBD options encoded in the filename as keyvalue pairs is deprecated.  Future versions may cease to parse these options in the future.
No errors were found on the image.
Image end offset: 262144


Thanks.

Comment 14 CongLi 2018-09-17 11:11:22 UTC
(In reply to CongLi from comment #13)
> Steps as comment 0.
> 
> Reproduced this issue on qemu-kvm-rhev-2.12.0-15.el7.x86_64:
> # qemu-img check test.qcow2
> qemu-img: Could not open '/home/test.qcow2': Could not open backing file:
> Parameter 'pool' is missing
> 
> Verified this bug on qemu-kvm-rhev-2.12.0-16.el7.x86_64:
> # qemu-img check test.qcow2
> qemu-img: RBD options encoded in the filename as keyvalue pairs is
> deprecated.  Future versions may cease to parse these options in the future.
> No errors were found on the image.
> Image end offset: 262144
> 
> 
> Thanks.

create a snapshot based on image on rbd with old-fashioned json format in RHEL.7.5.z: qemu-kvm-rhev-2.10.0-21.el7_5.3.x86_64

Comment 16 errata-xmlrpc 2018-11-01 11:13:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3443


Note You need to log in before you can comment on or make changes to this bug.