Bug 1610681 - ALT is ignored in mouse event
Summary: ALT is ignored in mouse event
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ncurses   
(Show other bugs)
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-01 08:06 UTC by Pavel Stehule
Modified: 2018-10-02 19:32 UTC (History)
3 users (show)

Fixed In Version: ncurses-6.1-8.20180923.fc29
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-10-02 19:32:17 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test case (860 bytes, text/x-csrc)
2018-08-01 08:06 UTC, Pavel Stehule
no flags Details

Description Pavel Stehule 2018-08-01 08:06:09 UTC
Created attachment 1472017 [details]
test case

Description of problem:

The combination ALT - mouse click doesn't work in FC28 in terminal applications. It was working in previous releases. The mouse event is processed, but the information about press the ALT key is lost. It is working when I connect from GUI to any older server by ssh. 

Version-Release number of selected component (if applicable):


How reproducible:

You can use pspg pager https://github.com/okbob/pspg where ALT + double click should to toggle bookmarks. Or you can check ncurses code

the check of event.bstate & BUTTON_ALT is newer true.


Steps to Reproduce:
1. compile gcc mouse_error.c -lncursesw
2. run it
3. click somewhere, try to click with ALT

Actual results:

this code doesn't stop on ALT click

Expected results:

stop on ALT click

Additional info:

Comment 1 Pavel Stehule 2018-08-01 08:36:17 UTC
I tested some others terminals, and it works on mrxvt terminal. And doesn't work with xterm too.

Comment 2 Miroslav Lichvar 2018-08-01 08:36:51 UTC
For reference, upstream discussion is here:
http://lists.gnu.org/archive/html/bug-ncurses/2018-07/msg00017.html

It would be interesting to try to bisect the change (ncurses snapshot) that caused it to stop working.

Comment 3 Pavel Stehule 2018-08-01 08:50:08 UTC
looks like term definition issue - I am not a expert on this area. 
export TERM=rxvt fix this isse. So maybe some wrong is in xterm* definition.

Comment 4 Thomas E. Dickey 2018-09-17 00:34:45 UTC
I started investigating this yesterday, will report when it's resolved.

Comment 5 Thomas E. Dickey 2018-09-22 20:18:13 UTC
It was something that I overlooked when coding the SGR-1006 logic in the mouse feature of ncurses.  I'd updated descriptions for terminals which support it in January.

rxvt probably will never support that feature, and no one has demonstrated interest in urxvt's similar feature by sending a working patch for it.

Comment 6 Miroslav Lichvar 2018-09-25 10:00:29 UTC
Thanks for the fix.

Comment 7 Fedora Update System 2018-09-25 10:27:57 UTC
ncurses-6.1-8.20180923.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-d1049d9af2

Comment 8 Fedora Update System 2018-09-27 02:10:30 UTC
ncurses-6.1-8.20180923.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-d1049d9af2

Comment 9 Pavel Stehule 2018-09-28 06:25:46 UTC
I tested it on Fedora 29 ncurses version: 6.1, patch: 20180923

and it the behave was not changed. It is not fixed.

Comment 10 Thomas E. Dickey 2018-09-28 07:51:43 UTC
I tested by modifying xterm's translations to permit space, control and alt, using the ncurses test-program.

Comment 11 Thomas E. Dickey 2018-09-28 07:52:30 UTC
(that's the original source, of course - the package "should" be the same).

Comment 12 Pavel Stehule 2018-09-28 08:11:22 UTC
I was wrong, I am sorry. The attached program works well. Thank you. But still it doesn't work with BUTTON5 and BUTTON4. Please, check test case with repleaced BUTTON1 by BUTTON4 or BUTTON5.

Comment 13 Thomas E. Dickey 2018-09-30 20:44:28 UTC
I can see that the wheel-mouse does not combine as expected (will investigate).

Comment 14 Fedora Update System 2018-10-02 19:32:17 UTC
ncurses-6.1-8.20180923.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.