Bug 161074 - KDE packages should use the --enable-new-ldflags ./configure option
KDE packages should use the --enable-new-ldflags ./configure option
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-20 09:22 EDT by Szombathelyi György
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 10:20:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Szombathelyi György 2005-06-20 09:22:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; hu-HU; rv:1.7.6) Gecko/20050318 Firefox/1.0.2

Description of problem:
KDE packages should use the --enable-new-ldflags ./configure option. This triggers the using of --enable-new-dtags and the --as-needed flag in the linker, which should filter out indirectly linked libraries from the NEEDED section of the ELF headers. The result is: much less dependencies in the packages. E.g the kdeadmin module really should not depend on libart_lgpl and there are many more examples.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Query the dependencies of a KDE package
2. It's much more than it should be
3.
  

Additional info:
Comment 1 Ngo Than 2006-01-18 10:20:01 EST
it's fixed in rawhide. Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.