Bug 1610994 - [3.10] Provision call failed: deploymentconfigs is forbidden: User cannot get deploymentconfigs in project
Summary: [3.10] Provision call failed: deploymentconfigs is forbidden: User cannot get...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Templates
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.z
Assignee: Ben Parees
QA Contact: Dongbo Yan
URL:
Whiteboard:
Depends On: 1562527 1610995
Blocks: 1610991
TreeView+ depends on / blocked
 
Reported: 2018-08-01 20:18 UTC by Ben Parees
Modified: 2018-08-31 06:18 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Groups associated w/ a user were not checked when performing access checks to look up the readiness of objects created by the templates. Consequence: For objects the user could only access due to their group membership, objects would be created by the template, but could not be checked for readiness, resulting in a readiness failure at the template instance level. Fix: Pass the user's groups when performing the readiness check operation, not just when performing the object creation. Result: Objects can successfully be checked for readiness as long as the user's group membership permits the check.
Clone Of: 1562527
Environment:
Last Closed: 2018-08-31 06:18:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2376 None None None 2018-08-31 06:18:51 UTC

Comment 1 Ben Parees 2018-08-02 17:38:05 UTC
https://github.com/openshift/ose/pull/1382

Comment 3 Dongbo Yan 2018-08-23 09:35:53 UTC
Test with
# openshift version
openshift v3.10.34

Reproduce steps:
1. Login openshift with user1 and create project 
2. Create user group and add admin role to group
$oc adm groups new testgroup user1 user2
$oc policy add-role-to-group admin testgroup -n testproject

3. Login to the webconsole as user2
4. Using the web console, switch to that testproject and add the httpd service catalog item, click through accepting defaults

5. Check serviceinstance status
$oc get serviceinstance
$oc describe serviceinstance/httpd-example-v8fpv

Actual result:
servicesintance is pending

Message:               Error provisioning ServiceInstance of ClusterServiceClass (K8S: "f560547b-a67a-11e8-9c1f-fa163ee057c4" ExternalName: "httpd-example") at ClusterServiceBroker "template-service-broker": Status: 409; ErrorMessage: <nil>; Description: <nil>; ResponseError: <nil>

Comment 4 Dongbo Yan 2018-08-23 11:11:56 UTC
Test with
openshift v3.10.35

cannot reproduce this issue, serviceinstance is ready

Comment 6 errata-xmlrpc 2018-08-31 06:18:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2376


Note You need to log in before you can comment on or make changes to this bug.