Bug 161123 - No syntax highlighting in VIM after FC4 upgrade
Summary: No syntax highlighting in VIM after FC4 upgrade
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 17:48 UTC by Ivan Marsh
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-21 09:14:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ivan Marsh 2005-06-20 17:48:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
After an upgrade of FC3 to FC4 vim no longer highlights syntax. Same results on two different boxes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run vim with a file that should be syntax highlighted.
2. Look at the screen.
  

Actual Results:  No syntax highlighting.

Expected Results:  Files should be syntax highlighted.

Additional info:

syntax on
syntax enabled

and creating a .vimrc that should turn on syntax highlight has no effect.

Both of the systems I've had this problem with worked fine before the upgrade.

Comment 1 Karsten Hopp 2005-06-21 09:14:37 UTC
I assume this is only happening for root and not for ordinary users with uids >
100 ?
Make sure you're running vim and not vi. (/usr/bin/vim vs. /bin/vi).
Due to many complaints the alias vi=vim isn't set anymore for uids < 100.
if you'd like to have the old behaviour back, add a line

  alias vi=vim

to your .bashrc


Note You need to log in before you can comment on or make changes to this bug.