Bug 1611834 - glusterfsd crashes when SEEK_DATA/HOLE is not supported
Summary: glusterfsd crashes when SEEK_DATA/HOLE is not supported
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: posix
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
: 1658327 (view as bug list)
Depends On:
Blocks: 1610825
TreeView+ depends on / blocked
 
Reported: 2018-08-02 20:55 UTC by Xavi Hernandez
Modified: 2018-12-14 07:12 UTC (History)
3 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-23 15:16:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Xavi Hernandez 2018-08-02 20:55:04 UTC
Description of problem:

When posix xlator is compiled on a platform that doesn't support SEEK_DATA/SEEK_HOLE options for a seek operation, the brick process crashes when the client tries to use it.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-08-02 21:03:30 UTC
REVIEW: https://review.gluster.org/20625 (posix: prevent crash when SEEK_DATA/HOLE is not supported) posted (#1) for review on master by Xavi Hernandez

Comment 2 Worker Ant 2018-08-03 22:20:49 UTC
COMMIT: https://review.gluster.org/20625 committed in master by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- posix: prevent crash when SEEK_DATA/HOLE is not supported

Instead of not defining the 'seek' fop when it's not supported on the
compilation platform, we simply return EINVAL when it's used.

Fixes: bz#1611834
Change-Id: I253666d8910c5e2fffa3a3ba37085e5c1c058a8e
Signed-off-by: Xavi Hernandez <xhernandez@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:16:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 4 Xavi Hernandez 2018-12-14 07:12:38 UTC
*** Bug 1658327 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.