Bug 161215 - Display garbled in graphical install and when X starts
Display garbled in graphical install and when X starts
Status: CLOSED DUPLICATE of bug 163331
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-21 10:28 EDT by Stewart Adcock
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-25 05:07:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adcock 2005-06-21 10:28:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Upon selecting the graphical install, the display is garbled (many vertical artifacts, shadowing of content, flickering, mouse pointer seems to be in three places...).  The display appears too long (vertically) to fit on the physical display - use of "linux lowres" fixes this, but the display is still garbled.  The content can, just about, be read.

The text-based install works normally but when X starts upon first boot, the display is similarly corrupted.

Once the corrupted display occurs, the text console screens are also garbled (hideous colours, rectanglar artifacts, nonsense characters located seemingly randomly on screen, no typing is visible but cursor appears to move correctly).

Partial Workaround:
1. Perform text-based install.
2. Endure the garbled display during the first-boot setup.
3. Use system-config-display to manually select correct monitor type (Dell D1226H).
4. Reboot.  (Just restarting X is insufficient.)

Note that the console screens are still corrupted once X begins.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Attempt graphical install from CD set.

Or:

1. Perform text-based install.
2. After install, boot as usual.
3. Start X, manually or otherwise.



Actual Results:  Display garbled, as described.

Expected Results:  Display not garbled.

Additional info:

AMD Athlon(tm) 64 Processor 3000+
512 MB
Matrox Graphics, Inc. MGA G550 AGP
Dell, Inc. D1226H 19" CRT Monitor 
IDE Disk 1 : QUANTUM FIREBALL ST3.2A
IDE Disk 2 : WDC WD1200JB-00CRA1
IDE Disk 3 : CD-RW CDR-2440MB
IDE Disk 4 : Pioneer DVD-ROM ATAPIModel DVD-115 0111
AT Translated Set 2 keyboard
ImPS/2 Generic Wheel Mouse
ALi Corporation M4 PCI AC-Link Controller Audio Device

The monitor is connected via an analogue cable.
Comment 1 Mike A. Harris 2005-06-22 17:37:45 EDT
Please review bug number 161242 everyone, and try using the libvgahw.a module
that is linked to from that bug report.  This is just a hunch I'd like
to test to see if the problem reported on Matrox and Intel hardware is also
causing problems on Trident and other hardware.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161242

Anyone who can test this and provide feedback, would be greatly appreciated.

Thanks in advance.
Comment 2 Stewart Adcock 2005-07-15 03:26:08 EDT
Niether of the fixes outlined in bug 161242, comment #94 fix this problem.  In
fact, the display is subjectively worse with the xorg-x11-6.8.2-43 rpms due to
increased flickering.
Comment 3 Stewart Adcock 2005-07-25 05:07:13 EDT

*** This bug has been marked as a duplicate of 163331 ***

Note You need to log in before you can comment on or make changes to this bug.