Bug 1612540 - librsvg2: Contains SSE2 instructions on i686
Summary: librsvg2: Contains SSE2 instructions on i686
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: librsvg2
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: x86Tracker
TreeView+ depends on / blocked
 
Reported: 2018-08-05 13:25 UTC by Ralf Corsepius
Modified: 2019-09-12 07:47 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-10 11:48:39 UTC
Type: Bug


Attachments (Terms of Use)
coredump's stacktrace (13.78 KB, text/plain)
2018-08-05 18:43 UTC, Ralf Corsepius
no flags Details
gdb disassembly of rsvg_internals::property_bag::PropertyBag::new_from_key_value_pairs (5.64 KB, text/plain)
2018-08-05 19:15 UTC, Ralf Corsepius
no flags Details

Description Ralf Corsepius 2018-08-05 13:25:51 UTC
Description of problem:
On an old PIII lightdm fails to start and dumps core.

...
Core was generated by `/usr/sbin/lightdm-gtk-greeter'.
Program terminated with signal SIGILL, Illegal instruction.
#0  0xb316af96 in rsvg_internals::property_bag::PropertyBag::new_from_key_value_pairs (pairs=<optimized out>) at rsvg_internals/src/property_bag.rs:83
83	rsvg_internals/src/property_bag.rs: No such file or directory.
...

Version-Release number of selected component (if applicable):
lightdm-gtk-2.0.5-1.fc28.i686

How reproducible:
Always

Actual results:
Coredump in /var/lib/systemd/coredump

Expected results:
Function. This did work with fc27

Comment 1 Ralf Corsepius 2018-08-05 13:50:02 UTC
Full coredump, as generated by systemd during system startup:
https://corsepiu.fedorapeople.org/misc/core.lightdm-gtk-gre.977.f7ab39cdead64691a10e6197b37bc7e7.1283.1533474789000000.lz4

Comment 2 leigh scott 2018-08-05 14:19:46 UTC
I no longer accept any i686 issues

Comment 3 Ralf Corsepius 2018-08-05 15:47:59 UTC
(In reply to leigh scott from comment #2)
> I no longer accept any i686 issues
With all due respect, I consider this attitude of you to be inacceptable.

Comment 4 Dominik 'Rathann' Mierzejewski 2018-08-05 15:59:45 UTC
Looking at the partial output I'm guessing the actual SIGILL happens inside librsvg, but we'd need to see the full stack trace to be sure.

Comment 5 leigh scott 2018-08-05 16:24:24 UTC

(In reply to Ralf Corsepius from comment #3)
> (In reply to leigh scott from comment #2)
> > I no longer accept any i686 issues
> With all due respect, I consider this attitude of you to be inacceptable.

I don't consider your P3 hardware is adequate to run fedora and is probably the cause of your issue.
There are no other i686 reports against lightdm-gtk.

Comment 6 Wolfgang Ulbrich 2018-08-05 18:02:44 UTC
> I consider this attitude of you to be inacceptable

Why people always talk about attitude from other people?
This is the real bad attitude ;)

i686 isn't primary arch any more, so what?
x64 cpus and ramm is really cheap nowadays, so why are you using a CPU from the 90th?
Maybe you like wasting electricity and heating up you apartment?

Sorry, i see no reason to support old cpus.

Comment 7 Florian Weimer 2018-08-05 18:30:37 UTC
(In reply to Ralf Corsepius from comment #1)
> Full coredump, as generated by systemd during system startup:
> https://corsepiu.fedorapeople.org/misc/core.lightdm-gtk-gre.977.
> f7ab39cdead64691a10e6197b37bc7e7.1283.1533474789000000.lz4

Would you please run “disassemble” at the point of the crash under GDB?

Comment 8 Ralf Corsepius 2018-08-05 18:40:48 UTC
(In reply to Wolfgang Ulbrich from comment #6)
Are you trolling? I guess so.

Comment 9 Ralf Corsepius 2018-08-05 18:41:39 UTC
(In reply to Dominik 'Rathann' Mierzejewski from comment #4)
> Looking at the partial output I'm guessing the actual SIGILL happens inside
> librsvg,
Yes, that's what the backtrace indicates

> but we'd need to see the full stack trace to be sure.
You have the coredump ;)

Comment 10 Ralf Corsepius 2018-08-05 18:43:38 UTC
Created attachment 1473486 [details]
coredump's stacktrace

Comment 11 Ralf Corsepius 2018-08-05 19:15:59 UTC
Created attachment 1473488 [details]
gdb disassembly of rsvg_internals::property_bag::PropertyBag::new_from_key_value_pairs

Comment 12 Ralf Corsepius 2018-08-05 19:17:15 UTC
(In reply to Florian Weimer from comment #7)
> Would you please run “disassemble” at the point of the crash under GDB?
Is the attachment to comment #11 what you want?

Comment 13 Wolfgang Ulbrich 2018-08-05 19:58:43 UTC
A second time you get personal to people here.
As co-manintainer from lightdm if subscribe for this reason,
Looks like you can speak with yourself here ;)

Comment 14 Ralf Corsepius 2018-08-06 03:26:09 UTC
(In reply to Wolfgang Ulbrich from comment #13)
> A second time you get personal to people here.
To make this clear: YOU got personal, YOU violently refuse to do YOUR job.

Comment 15 Dominik 'Rathann' Mierzejewski 2018-08-06 14:59:17 UTC
Ralf, you cannot tell volunteer packagers what to do for free. Demanding anything will get you nothing except bad reputation. Your attitude is definitely not excellent. It's not anyone's job to fix this bug for you unless you have a contract with them. If you ask politely and provide as much as assistance as possible then the (volunteer!) maintainers might just be able and willing to fix it. Also, bugzilla is not the place for such discussions, so please take it to the devel list if you must. Please be more civil.

Comment 16 Ralf Corsepius 2018-08-06 15:42:19 UTC
(In reply to Dominik 'Rathann' Mierzejewski from comment #15)
> Ralf, you cannot tell volunteer packagers what to do for free.
I would have had any problem with Scott telling "can't don't have the HW and can't" test, but confronting me with a "I do not support the arch" IMO is a hostile act.

> Demanding
> anything will get you nothing except bad reputation. Your attitude is
> definitely not excellent. It's not anyone's job to fix this bug for you
Correct, but the border between maintaining and pretending to be a maintainer is very narrow.

> Please be more civil.
Actually, I am really pissed off by the attitude certain people exhibit here.
IMO, these people do not do their job in reasonable manners and should not be part of the Fedora project.

Comment 17 leigh scott 2018-08-06 19:31:22 UTC
(In reply to Ralf Corsepius from comment #16)
> (In reply to Dominik 'Rathann' Mierzejewski from comment #15)
> > Ralf, you cannot tell volunteer packagers what to do for free.
> I would have had any problem with Scott telling "can't don't have the HW and
> can't" test, but confronting me with a "I do not support the arch" IMO is a
> hostile act.

Comment#2 was meant for the other maintainers, it was to inform them I wasn't going to work on the issue.

reasons why:

1. I'm too busy to work on secondary arch issues, there are more than 12 updates  on my todo list that have been waiting nearly a month already.
2. I've been x86_64 only since FC5.
3. I believe your issue is caused by inadequate hardware as there are no other reports similar to this.


> 
> > Demanding
> > anything will get you nothing except bad reputation. Your attitude is
> > definitely not excellent. It's not anyone's job to fix this bug for you
> Correct, but the border between maintaining and pretending to be a
> maintainer is very narrow.

Since I haven't used lightdm-gtk since F28 I have decided to relinquish commit & watch rights.

> 
> > Please be more civil.
> Actually, I am really pissed off by the attitude certain people exhibit here.
> IMO, these people do not do their job in reasonable manners and should not
> be part of the Fedora project.

When are you leaving? as you have been the nasty hostile one here.

Comment 18 leigh scott 2018-08-06 19:33:03 UTC
(In reply to leigh scott from comment #17)

> Since I haven't used lightdm-gtk since F28 I have decided to relinquish
> commit & watch rights.

The F28 was a typo, it was F26.

Comment 19 Florian Weimer 2018-08-06 19:34:56 UTC
The culprit seems to be librsvg2.  SSE2 instructions are permitted on i686 only in Fedora 29, not Fedora 28.  But given that the ban will be lifted anyway soon enough, this certainly looks like a very low-priority bug to me.

Comment 20 Igor Raits 2018-08-10 11:48:39 UTC
So I could do excludearch for i686... Or wait until arch gets dropped.

I do agree with you that F28 should have not got this... But we needed newer version which is powered up by Rust.

Or actually close this bug as WONTFIX.

Comment 21 Dominik 'Rathann' Mierzejewski 2018-08-10 17:15:51 UTC
(In reply to Igor Gnatenko from comment #20)
> So I could do excludearch for i686...

In the middle of stable release life cycle? I don't think so.

> Or wait until arch gets dropped.

Yes.

> I do agree with you that F28 should have not got this... But we needed newer
> version which is powered up by Rust.

You should not have done the update in this case, at least not in F28 and lower.

> Or actually close this bug as WONTFIX.

That's not very nice.

Comment 22 r3obh 2019-09-12 04:52:32 UTC
(In reply to leigh scott from comment #5)
> 
> (In reply to Ralf Corsepius from comment #3)
> > (In reply to leigh scott from comment #2)
> > > I no longer accept any i686 issues
> > With all due respect, I consider this attitude of you to be inacceptable.
> 
> I don't consider your P3 hardware is adequate to run fedora and is probably
> the cause of your issue.
> There are no other i686 reports against lightdm-gtk.

I consider my P3 hardware perfectly adequate to run Fedora, for example since I'm posting this
from epiphany on LXDE on FC27 on it.  It work well apart from gradual slow down due to bloat,
and being "deprecated" by too many SSE2 bugs, librsvg2 being one of several offenders.

- R


Note You need to log in before you can comment on or make changes to this bug.