Bug 1612601 - [abrt] firefox: mozilla::ipc::MessageChannel::OnChannelErrorFromLink()(): firefox killed by SIGSEGV
Summary: [abrt] firefox: mozilla::ipc::MessageChannel::OnChannelErrorFromLink()(): fir...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 28
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:ed00fca20d43645fa524ecd3221...
Keywords:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2018-08-05 19:34 UTC by dn49i7+hdm8u5shsmcg
Modified: 2018-11-11 03:12 UTC (History)
13 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-11-11 03:12:31 UTC


Attachments (Terms of Use)
File: backtrace (53.05 KB, text/plain)
2018-08-05 19:34 UTC, dn49i7+hdm8u5shsmcg
no flags Details
File: cgroup (195 bytes, text/plain)
2018-08-05 19:34 UTC, dn49i7+hdm8u5shsmcg
no flags Details
File: core_backtrace (200.11 KB, text/plain)
2018-08-05 19:34 UTC, dn49i7+hdm8u5shsmcg
no flags Details
File: cpuinfo (513 bytes, text/plain)
2018-08-05 19:34 UTC, dn49i7+hdm8u5shsmcg
no flags Details
File: dso_list (11.98 KB, text/plain)
2018-08-05 19:34 UTC, dn49i7+hdm8u5shsmcg
no flags Details
File: environ (2.14 KB, text/plain)
2018-08-05 19:34 UTC, dn49i7+hdm8u5shsmcg
no flags Details
File: limits (1.29 KB, text/plain)
2018-08-05 19:34 UTC, dn49i7+hdm8u5shsmcg
no flags Details
File: maps (52.72 KB, text/plain)
2018-08-05 19:34 UTC, dn49i7+hdm8u5shsmcg
no flags Details
File: mountinfo (3.58 KB, text/plain)
2018-08-05 19:34 UTC, dn49i7+hdm8u5shsmcg
no flags Details
File: open_fds (2.82 KB, text/plain)
2018-08-05 19:34 UTC, dn49i7+hdm8u5shsmcg
no flags Details
File: proc_pid_status (1.11 KB, text/plain)
2018-08-05 19:34 UTC, dn49i7+hdm8u5shsmcg
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 171671 None None None 2018-09-24 14:08 UTC
Red Hat Bugzilla 1633565 None None None Never

Internal Trackers: 1633565

Description dn49i7+hdm8u5shsmcg 2018-08-05 19:34:31 UTC
Version-Release number of selected component:
firefox-61.0.1-3.fc28

Additional info:
reporter:       libreport-2.9.5
backtrace_rating: 4
cmdline:        /usr/lib64/firefox/firefox -contentproc -childID 1 -isForBrowser -prefsLen 9610 -schedulerPrefs 0001,2 -greomni /usr/lib64/firefox/omni.ja -appomni /usr/lib64/firefox/browser/omni.ja -appdir /usr/lib64/firefox/browser 10052 tab
crash_function: mozilla::ipc::MessageChannel::OnChannelErrorFromLink()
executable:     /usr/lib64/firefox/firefox
journald_cursor: s=2bc2a7f7a9c249e79d77a8ac7b6bf863;i=8b9;b=be047efc69a74eeb82f114bfc4e3ab3c;m=2cb9d442;t=572b52f74ad42;x=7c9bd27503744589
kernel:         4.17.12-200.amdgpu.fc28.ppc64le
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 0 (10 frames)
 #0 mozilla::ipc::MessageChannel::OnChannelErrorFromLink() at /usr/src/debug/firefox-61.0.1-3.fc28.ppc64le/ipc/glue/MessageChannel.cpp:2556
 #1 mozilla::ipc::ProcessLink::OnChannelError() at /usr/src/debug/firefox-61.0.1-3.fc28.ppc64le/ipc/glue/MessageLink.cpp:393
 #2 IPC::Channel::ChannelImpl::OnFileCanReadWithoutBlocking(int) at /usr/src/debug/firefox-61.0.1-3.fc28.ppc64le/ipc/chromium/src/chrome/common/ipc_channel_posix.cc:822
 #3 base::MessagePumpLibevent::OnLibeventNotification(int, short, void*) at /usr/src/debug/firefox-61.0.1-3.fc28.ppc64le/ipc/chromium/src/base/message_pump_libevent.cc:255
 #4 event_persist_closure at /usr/src/debug/firefox-61.0.1-3.fc28.ppc64le/ipc/chromium/src/third_party/libevent/event.c:1580
 #5 event_process_active_single_queue at /usr/src/debug/firefox-61.0.1-3.fc28.ppc64le/ipc/chromium/src/third_party/libevent/event.c:1639
 #6 event_process_active at /usr/src/debug/firefox-61.0.1-3.fc28.ppc64le/ipc/chromium/src/third_party/libevent/event.c:1738
 #7 event_base_loop at /usr/src/debug/firefox-61.0.1-3.fc28.ppc64le/ipc/chromium/src/third_party/libevent/event.c:1961
 #8 base::MessagePumpLibevent::Run(base::MessagePump::Delegate*) at /usr/src/debug/firefox-61.0.1-3.fc28.ppc64le/ipc/chromium/src/base/message_pump_libevent.cc:381
 #9 MessageLoop::RunInternal() at /usr/src/debug/firefox-61.0.1-3.fc28.ppc64le/ipc/chromium/src/base/message_loop.cc:592

Comment 1 dn49i7+hdm8u5shsmcg 2018-08-05 19:34:39 UTC
Created attachment 1473490 [details]
File: backtrace

Comment 2 dn49i7+hdm8u5shsmcg 2018-08-05 19:34:40 UTC
Created attachment 1473491 [details]
File: cgroup

Comment 3 dn49i7+hdm8u5shsmcg 2018-08-05 19:34:45 UTC
Created attachment 1473492 [details]
File: core_backtrace

Comment 4 dn49i7+hdm8u5shsmcg 2018-08-05 19:34:46 UTC
Created attachment 1473493 [details]
File: cpuinfo

Comment 5 dn49i7+hdm8u5shsmcg 2018-08-05 19:34:48 UTC
Created attachment 1473494 [details]
File: dso_list

Comment 6 dn49i7+hdm8u5shsmcg 2018-08-05 19:34:49 UTC
Created attachment 1473495 [details]
File: environ

Comment 7 dn49i7+hdm8u5shsmcg 2018-08-05 19:34:51 UTC
Created attachment 1473496 [details]
File: limits

Comment 8 dn49i7+hdm8u5shsmcg 2018-08-05 19:34:53 UTC
Created attachment 1473497 [details]
File: maps

Comment 9 dn49i7+hdm8u5shsmcg 2018-08-05 19:34:55 UTC
Created attachment 1473498 [details]
File: mountinfo

Comment 10 dn49i7+hdm8u5shsmcg 2018-08-05 19:34:57 UTC
Created attachment 1473499 [details]
File: open_fds

Comment 11 dn49i7+hdm8u5shsmcg 2018-08-05 19:34:58 UTC
Created attachment 1473500 [details]
File: proc_pid_status

Comment 12 bztdlinux 2018-09-09 23:17:26 UTC
Similar problem has been detected:

Typing in the Firefox address bar on ppc64le on a Talos

reporter:       libreport-2.9.5
backtrace_rating: 4
cmdline:        /usr/lib64/firefox/firefox -contentproc -childID 1 -isForBrowser -prefsLen 5548 -schedulerPrefs 0001,2 -parentBuildID 20180904094357 -greomni /usr/lib64/firefox/omni.ja -appomni /usr/lib64/firefox/browser/omni.ja -appdir /usr/lib64/firefox/browser 3454 tab
crash_function: mozilla::ipc::MessageChannel::OnChannelErrorFromLink()
executable:     /usr/lib64/firefox/firefox
journald_cursor: s=7de50377476c41018f0433caac4b36c1;i=3875;b=309021d3f9ad4bcc86613b4aef5fe17a;m=53b8700;t=57578384f1c3f;x=c1049d1430904ea9
kernel:         4.17.19-200.fc28.ppc64le
package:        firefox-62.0-2.fc28
reason:         firefox killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 13 Dan Horák 2018-09-24 10:32:38 UTC
Is anyone able to reproduce the crash with FF from the mozilla-central repo (top of the upstream repo)?

Comment 14 bztdlinux 2018-09-24 16:57:30 UTC
mozilla-central doesn't build due to issues related to:

https://fedoraproject.org/wiki/Changes/PPC64LE_Float128_Transition

Comment 15 Dan Horák 2018-09-27 13:22:07 UTC
Not sure it's exactly related to the Float128 transition change, but I have reported the rust crash due float128 in bug 1633565.

Comment 16 Fedora Update System 2018-11-09 09:11:09 UTC
firefox-63.0.1-5.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-e485c3c4cb

Comment 17 Fedora Update System 2018-11-11 03:12:31 UTC
firefox-63.0.1-5.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.