Bug 161273 - Error in processing package exclude lists from a kickstart file
Summary: Error in processing package exclude lists from a kickstart file
Status: CLOSED DUPLICATE of bug 160209
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-21 22:31 UTC by Antti Andreimann
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-22 03:22:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Antti Andreimann 2005-06-21 22:31:44 UTC
Description of problem:
Exception on line 1559 of /usr/lib/anaconda/kickstart.py when trying to exclude
packages from a kickstart file by using the following in %packages section
-package-name
The alternate syntax works:
-package-name.arch

Reason:
Line 1559 in /usr/lib/anaconda/kickstart.py refers to a variable "name" which is
uninitialized in this scope.

Fix:
replace [name] with [n] on line 1559 at /usr/lib/anaconda/kickstart.py

Comment 1 Jeremy Katz 2005-06-22 03:22:14 UTC

*** This bug has been marked as a duplicate of 160209 ***


Note You need to log in before you can comment on or make changes to this bug.