Bug 1612863
| Summary: | Change in 3.9.33 docker_image_availability check causing failed pre-install | ||
|---|---|---|---|
| Product: | OpenShift Container Platform | Reporter: | Paul Dwyer <pdwyer> |
| Component: | Installer | Assignee: | Vadim Rutkovsky <vrutkovs> |
| Status: | CLOSED ERRATA | QA Contact: | Johnny Liu <jialiu> |
| Severity: | medium | Docs Contact: | |
| Priority: | unspecified | ||
| Version: | 3.9.0 | CC: | aos-bugs, jokerman, mmccomas, pdwyer |
| Target Milestone: | --- | ||
| Target Release: | 3.9.z | ||
| Hardware: | x86_64 | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2018-09-22 04:53:09 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
Vadim, I think we need to refactor this so that the osm_etcd_image variable continues to work as expected since it's documented in the example inventories. Please attach the inventory and full `ansible-playbook -vvv` output. This change would only affect default settings, so `osm_etcd_image` would be used for Enterprise setup. If `etcd_image` is set, it would override any of those. Created PR https://github.com/openshift/openshift-ansible/pull/9461 to revert this commit - it was introduced to fix CI failures, so it should be reverted if it breaks existing inventories Seem like this bug is already fixed. Verified this bug with openshift-ansible-3.9.43-1.git.0.d0bc600.el7.noarch, and PASS.
Trigger an container install, and set openshift_image_tag=v3.9.33 and osm_etcd_image, pre-install is passed.
CHECK [docker_image_availability : host-8-252-211.host.centralci.eng.rdu2.redhat.com] ***
CHECK [memory_availability : host-8-252-211.host.centralci.eng.rdu2.redhat.com] ***
changed: [host-8-252-211.host.centralci.eng.rdu2.redhat.com] => {"changed": true, "checks": {"disk_availability": {}, "docker_image_availability": {"changed": true}, "docker_storage": {}, "memory_availability": {}, "package_availability": {"skipped": true, "skipped_reason": "Not active for this host"}, "package_version": {"skipped": true, "skipped_reason": "Not active for this host"}}, "failed": false, "playbook_context": "install"}
Actually this is already fixed in present release version - 3.9.41.
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2018:2658 |
Description of problem: variable for etcd_img has changed between 3.9.14-1 and 3.9.33, due to this installation fails using existing "working" inventory Line 190 of `/usr/share/ansible/openshift-ansible/playbooks/cluster- operator/aws/roles/openshift_health_checker/openshift_checks/docker_ima ge_availability.py` Version: 3.9.14-1 etcd_img = self.get_var("osm_etcd_image", default="registry.access.redhat.com/rhel7/etcd") Version: 3.9.33 etcd_img = self.get_var("etcd_image", default="registry.access.redhat.com/rhel7/etcd") Version-Release number of the following components: openshift-ansible-3.9.33-1.git.56.19ba16e.el7 How reproducible: Steps to Reproduce: 1. Using "working" inventory that installed 3.9.14 and set "osm_etcd_image" try to install version 3.9.33 2. image availability checks fail Actual results: image availability check fails Expected results: Installation to succeed Additional info: No change to this variable is in release notes for 3.9.33 Looks like this change was made upstream https://github.com/openshift/openshift-ansible/commit/1f1eb5ddd526b48fbf3351ac88cf276215cf4db4