Bug 161292 - Why does OO think this page needs to be shrunk?
Summary: Why does OO think this page needs to be shrunk?
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-22 03:00 UTC by Jonathan Kamens
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-27 13:00:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OO Impress file which OO insists on shrinking (8.85 KB, application/octet-stream)
2005-06-22 03:00 UTC, Jonathan Kamens
no flags Details

Description Jonathan Kamens 2005-06-22 03:00:34 UTC
When I print the attached OpenOffice Impress file, it tells me that it's bigger
than the "print range" and needs to be shrunk.

Print range isn't defined anywhere in the documentation.  The documentation
doesn't say where OO gets the "print range" dimensions from.  I can't figure out
where it's getting it from, and in any case it's wrong.

If I tell it I want to "Trim" the document rather than fitting it, the document
prints just fine.  What's annoying is that I have to do this every single time I
print -- there's no way to make this setting sticky so OO will stop asking me
about it.

I have 1.9.109-1.2.0.fc5.

Comment 1 Jonathan Kamens 2005-06-22 03:00:34 UTC
Created attachment 115792 [details]
OO Impress file which OO insists on shrinking

Comment 2 Jonathan Kamens 2005-06-22 03:04:41 UTC
Incidentally, the printer driver has a defined imageable area margin of 36
points on each side.  I wonder if this is where CUPS is getting its "print
range" from.  It's difficult to know what to set these values to in
system-config-printer, since they aren't documented anywhere (including in the
HTML page that comes up if you click on "Help" on the "Queue Options" page where
these options are set).


Comment 3 Caolan McNamara 2005-06-27 13:00:59 UTC
OOo gets this information from CUPS as to what part of the page is addressable
by the printer, if the margins set by the user are outside this range it gives
the above error. AFAIK you can't/shouldn't override this area because your
printer cannot physically print to that part of the page, or at least so the
definition for the printer claims.


Note You need to log in before you can comment on or make changes to this bug.