Bug 1612984 - avc denied errors generated after restarting ipmi service
Summary: avc denied errors generated after restarting ipmi service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-06 16:47 UTC by Rachel Sibley
Modified: 2018-10-30 10:09 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.13.1-212.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:08:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:09:18 UTC

Description Rachel Sibley 2018-08-06 16:47:50 UTC
Description of problem:
Starting or stopping the ipmi service results in avc denied messages using the latest selinux-policy

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-210.el7.noarch
3.10.0-931.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. systemctl restart ipmi
2.
3.

Actual results:
time->Mon Aug  6 12:40:01 2018
type=PROCTITLE msg=audit(1533573601.763:165): proctitle=6D6F6470726F62650069706D695F7369
type=SYSCALL msg=audit(1533573601.763:165): arch=c000003e syscall=9 success=no exit=-13 a0=0 a1=5c6b3 a2=1 a3=2 items=0 ppid=16526 pid=16535 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="modprobe" exe="/usr/bin/kmod" subj=system_u:system_r:ipmievd_t:s0 key=(null)
type=AVC msg=audit(1533573601.763:165): avc:  denied  { map } for  pid=16535 comm="modprobe" path="/usr/lib/modules/3.10.0-931.el7.x86_64/modules.dep.bin" dev="dm-0" ino=33554501 scontext=system_u:system_r:ipmievd_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=file permissive=0
----
time->Mon Aug  6 12:40:01 2018
type=PROCTITLE msg=audit(1533573601.972:166): proctitle=6D6F6470726F62650069706D695F646576696E7466
type=SYSCALL msg=audit(1533573601.972:166): arch=c000003e syscall=9 success=no exit=-13 a0=0 a1=5c6b3 a2=1 a3=2 items=0 ppid=16526 pid=16539 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="modprobe" exe="/usr/bin/kmod" subj=system_u:system_r:ipmievd_t:s0 key=(null)
type=AVC msg=audit(1533573601.972:166): avc:  denied  { map } for  pid=16539 comm="modprobe" path="/usr/lib/modules/3.10.0-931.el7.x86_64/modules.dep.bin" dev="dm-0" ino=33554501 scontext=system_u:system_r:ipmievd_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=file permissive=0
----
time->Mon Aug  6 12:40:01 2018
type=PROCTITLE msg=audit(1533573601.739:164): proctitle=6D6F6470726F62650069706D695F6D736768616E646C6572
type=SYSCALL msg=audit(1533573601.739:164): arch=c000003e syscall=9 success=no exit=-13 a0=0 a1=5c6b3 a2=1 a3=2 items=0 ppid=16526 pid=16530 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="modprobe" exe="/usr/bin/kmod" subj=system_u:system_r:ipmievd_t:s0 key=(null)
type=AVC msg=audit(1533573601.739:164): avc:  denied  { map } for  pid=16530 comm="modprobe" path="/usr/lib/modules/3.10.0-931.el7.x86_64/modules.dep.bin" dev="dm-0" ino=33554501 scontext=system_u:system_r:ipmievd_t:s0 tcontext=system_u:object_r:modules_object_t:s0 tclass=file permissive=0


Expected results:
No AVC denied messages

Additional info:

Comment 5 errata-xmlrpc 2018-10-30 10:08:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.