Bug 161304 - Window list does not show window after switching workspace
Summary: Window list does not show window after switching workspace
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libwnck
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC4Update
TreeView+ depends on / blocked
 
Reported: 2005-06-22 09:03 UTC by Albert Bachmann
Modified: 2014-06-18 09:07 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-09-08 01:03:23 UTC


Attachments (Terms of Use)

Description Albert Bachmann 2005-06-22 09:03:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I upgraded from Fedora Core 3 to 4 using the installation CDs. There where no observable difficulties during this process. I now face a problem with the window list applet. It affects my old user account and newly created users as well if the applet is configured to show windows from all workspaces. See below for reproduction steps.

Version-Release number of selected component (if applicable):
gnome-applets-2.10.1-9

How reproducible:
Always

Steps to Reproduce:
1. Configure "Window List Preferences" with "Show windows from all workspaces".
2. Start an application.
3. Move to another workspace
4. Klick on the window list button representing the running application from other workspace.
  

Actual Results:  Nothing happens.

Expected Results:  There should be a switch to the workspace where the application started and the window should re-appear.

Additional info:

This behavior affects only newly started applications. When multiple applications run, one can first switch to an older application and then switch to the new one which is then shown properly.

Comment 1 Ray Strode [halfline] 2005-06-22 14:05:40 UTC
Hmm... This is either a libwnck bug or a Metacity bug.  For now I'm going to
assign it to libwnck.

Comment 2 Petr Šplíchal 2005-08-10 19:29:15 UTC
futhermore -- if "restore to native workspace" is set and you click on button of
a window that is on another workspace, workspace isn't switched and the clicked
window appears (moves) to current workspace

Comment 3 Jerry 2005-08-23 06:06:16 UTC
I will confirm comment #2.  Restore to native workspace worked fine yesterday. 
It acts like restore to current workspace now after todays update to metacity.

Comment 4 Graham Cole 2005-08-24 06:14:49 UTC
This might be related to bug id #165859.

Comment 5 Elijah Newren 2006-05-04 23:50:26 UTC
This is http://bugzilla.gnome.org/show_bug.cgi?id=331661, which was fixed in
libwnck 2.13.x upstream (if you want to backport, be sure to fix the bug that
was caused by the fix from that bug; see
http://bugzilla.gnome.org/show_bug.cgi?id=335316).

Comment 6 Søren Sandmann Pedersen 2006-09-08 01:03:23 UTC
Should be fixed in rawhide, please reopen if not.


Note You need to log in before you can comment on or make changes to this bug.