Bug 161335 - mt tell says no such device
mt tell says no such device
Status: CLOSED DUPLICATE of bug 161156
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-22 11:00 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-23 14:38:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2005-06-22 11:00:04 EDT
"mt tell" says no such device with kernel-2.6.9-5.0.5.EL.
Patch below:

--- st.c 2005-04-13 10:45:00.240790000 +0100
+++ st.c.new 2005-04-13 13:44:41.356696328 +0100
@@ -3126,8 +3126,9 @@
* access to the device is prohibited.
*/
retval = scsi_nonblockable_ioctl(STp->device, cmd_in, p, file);
- if (!scsi_block_when_processing_errors(STp->device) || !retval)
+ if (!scsi_block_when_processing_errors(STp->device) || retval != -ENODEV)
goto out;
+ retval = 0;
 
cmd_type = _IOC_TYPE(cmd_in);
cmd_nr = _IOC_NR(cmd_in);
Comment 1 Jason Baron 2005-06-23 14:38:11 EDT

*** This bug has been marked as a duplicate of 161156 ***

Note You need to log in before you can comment on or make changes to this bug.