Bug 1613379 - replace=1 on sysctl plugin not working on profiles
Summary: replace=1 on sysctl plugin not working on profiles
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.5
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Robin Hack
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-07 13:06 UTC by Jorge Andrade
Modified: 2019-08-06 13:05 UTC (History)
6 users (show)

Fixed In Version: tuned-2.11.0-0.1.rc1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 13:04:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2201 None None None 2019-08-06 13:05:15 UTC

Description Jorge Andrade 2018-08-07 13:06:19 UTC
Description of problem:


Version-Release number of selected component (if applicable):

tuned-2.9.0-1.el7.noarch

How reproducible:

Create a custom profile named test-profile, with the following configuration. 

/etc/tuned/test-profile/tuned.conf

[main]
include=throughput-performance

[sysctl]
replace=1
vm.swappiness=15


Steps to Reproduce:
1. tuned-adm profile test-profile
2. tuned-adm active shows test-profile


Actual results:

[root@XX tuned]# sysctl vm.swappiness
vm.swappiness = 10
[root@XX tuned]# sysctl vm.dirty_ratio
vm.dirty_ratio = 40 # This should the default value for vm.dirty_ratio and show the configured value on throughput-performance profile


Expected results:

[root@XX tuned]# sysctl vm.swappiness
vm.swappiness = 10
[root@XX tuned]# sysctl vm.dirty_ratio
vm.dirty_ratio = 20 # This should be proper value for vm.dirty_ratio as this is the default on RHEL 7.5

Additional info:

Modifying the configuration for /etc/tuned/test-profile/tuned.conf

[main]
include=throughput-performance

[sysctl]
replace=true # <---- Set this to true (all lower case)
vm.swappiness=15

It works.

But the documentation from tuned.conf(5) instructs to set the value for replace to 0 or 1.

Comment 2 Ondřej Lysoněk 2018-08-07 14:13:03 UTC
I'm a bit confused from your actual/expected results. Do I understand it correctly that this is simply a request to make 'replace=1' behave the same way as 'replace=true'?

Thanks.

Comment 3 Jorge Andrade 2018-08-08 04:48:14 UTC
Documentation doesn't reference replace=true only replace=1.

So the request will be to update the documentation or the make 'replace=1' work the same as 'replace=true'

Comment 10 errata-xmlrpc 2019-08-06 13:04:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2201


Note You need to log in before you can comment on or make changes to this bug.