Bug 16135 - CD ejects when mounted
Summary: CD ejects when mounted
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-14 00:39 UTC by Rogelio Noriega
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-06 17:15:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rogelio Noriega 2000-08-14 00:39:11 UTC
CD can be ejected from drive while it is mounted and thus causing a bunch 
of failure.  From my understanding, in RH6.2 the CD would not eject unless 
it is unmounted first.

Comment 1 Preston Brown 2000-08-14 16:21:29 UTC
during installation or after you are up and running? I assume during
installation.

Comment 2 Erik Troan 2000-08-14 18:40:58 UTC
I can't reproduce this in anaconda. I've heard magicdev causes this, but that's
still a kernel bug. I don't know why kernel folks seem to insist that it's
reasonable for a userspace program to break the kernel by repeatedly opening a
device. Good idea or not, it shouldn't affect the kernel.

Comment 3 Michael K. Johnson 2000-08-14 19:03:14 UTC
The kernel asks the drive to lock its door.  Lots of cdrom drives
are buggy and don't actually lock the door when they say they do.
I fail to see how this is a Linux kernel bug.

Comment 4 Rogelio Noriega 2000-08-29 13:16:58 UTC
We are using the same systems that we tested 6.2 on and the cdrom did not eject 
when mounted I don't think our hardware is the problem.

Comment 5 Rogelio Noriega 2000-09-06 17:15:29 UTC
After the install and RH is up and running you can eject the cd.


Note You need to log in before you can comment on or make changes to this bug.