Bug 1613835 - setting in gnome-tweak-tool Window List will reset upon opening
Summary: setting in gnome-tweak-tool Window List will reset upon opening
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell-extensions
Version: 7.6
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-08 11:47 UTC by Michal Odehnal
Modified: 2020-09-29 20:22 UTC (History)
6 users (show)

Fixed In Version: gnome-shell-extensions-3.28.1-13.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-29 20:21:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
proposed patch (1.24 KB, patch)
2020-04-17 07:24 UTC, Milan Crha
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 4990951 0 None None None 2020-04-16 02:57:35 UTC
Red Hat Product Errata RHBA-2020:3987 0 None None None 2020-09-29 20:22:25 UTC

Description Michal Odehnal 2018-08-08 11:47:09 UTC
Description of problem:
While setting Window List under Extensions tab in tweak-tools, the setting will reset upon opening the window. 

Version-Release number of selected component (if applicable):
gnome-tweak-tool-3.28.1-2.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Open gnome-tweak-tool.
2. Go to Extensions tab.
3. Open Window List setting (gear button).
4. Set Always group windows.
5. Close Window List window.
6. Open Window List setting (gear button) again.

Actual results:
Setting is back to Never group windows.

Expected results:
My setting gets saved/will not get reset upon opening the window.

Additional info:

Comment 2 Michal Odehnal 2018-08-08 12:08:12 UTC
Upon closer look, the setting will get saved the moment I close the Window List. As I am able to see multiple instances of terminal grouping and ungrouping. But only after closing the Window List. This setting will reset once the Window List is opened again.

Also should mention the AlternateTab is working well, I would expect the same from Window List as they seem like exact copies.

Comment 3 Carlos Soriano 2018-09-04 11:21:16 UTC
I tried with dconf, and seems the keys cannot be found somehow, so it's seems an issue with gnome-shell-extensions or so.

Comment 4 Carlos Soriano 2018-09-04 11:49:35 UTC
I can reproduce with gnome-shell-extension-tool, so seems the issue is there. the setting is changed in dconf fine.

Comment 5 Florian Müllner 2018-09-04 14:11:07 UTC
(In reply to Carlos Soriano from comment #4)
> I can reproduce with gnome-shell-extension-tool, so seems the issue is
> there.

I doubt it - the only settings gnome-shell-extension-prefs knows about are the relevant settings in org.gnome.shell (enabled-extensions and disable-user-extensions).

The settings from individual extension settings are handled by the preference widget that is supplied by the extension, so that's more likely the source.

Comment 7 Milan Crha 2020-04-17 07:23:08 UTC
Florian is right, the problem is in gnome-shell-extensions, thus I move this there. This [1] is a link to an upstream fix.

[1] https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests/119

Comment 8 Milan Crha 2020-04-17 07:24:08 UTC
Created attachment 1679581 [details]
proposed patch

The upstream fix does not apply to RHEL sources, this is the version, which does.

Comment 12 Michal Odehnal 2020-05-28 13:31:00 UTC
Unable to reproduce with gnome-shell-extensions-3.28.1-13.el7.

Comment 14 errata-xmlrpc 2020-09-29 20:21:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (GNOME bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3987


Note You need to log in before you can comment on or make changes to this bug.