Bug 1613841 - Bare domain doesn't get SSL
Summary: Bare domain doesn't get SSL
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
: 1613842 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-08 11:56 UTC by Amye Scavarda
Modified: 2018-10-10 01:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-10 01:14:22 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
gluster.org error screenshot (71.79 KB, image/png)
2018-08-08 11:56 UTC, Amye Scavarda
no flags Details

Description Amye Scavarda 2018-08-08 11:56:19 UTC
Created attachment 1474303 [details]
gluster.org error screenshot

Description of problem:
Weirdest thing: in Firefox, https://gluster.org gives bad_ssl_cert domain. 
See screenshot. 

Maybe something with the Let's Encrypt certificate, maybe something with Supercolony. 


How reproducible:
Firefox isolated, doesn't happen on Chrome

Comment 1 Nigel Babu 2018-08-08 12:05:58 UTC
Okay, so we have a cert for www.gluster.org but not one for gluster.org. Most of us don't reproduce the issue because we have a 301 redirect in place. I can reproduce this with curl.

$ curl -I https://gluster.org
curl: (51) SSL: no alternative certificate subject name matches target host name 'gluster.org'

Comment 2 Nigel Babu 2018-08-13 02:55:13 UTC
*** Bug 1613842 has been marked as a duplicate of this bug. ***

Comment 3 Nigel Babu 2018-08-13 02:56:50 UTC
Michael, could you add an SSL cert for gluster.org so that the redirects from https://gluster.org -> https://www.gluster.org do not throw SSL errors?

Comment 4 sankarshan 2018-08-20 01:56:39 UTC
Should this not be assigned to Michael and status changed?

Comment 5 M. Scherer 2018-10-09 16:41:20 UTC
This seems to be fixed :

$ curl -I https://gluster.org
HTTP/1.1 302 Found
Date: Tue, 09 Oct 2018 16:40:12 GMT
Server: Apache
Location: https://www.gluster.org/
Connection: close
Content-Type: text/html; charset=iso-8859-1

Could people confirm that is not some weird case regarding curl ?

Comment 6 Nigel Babu 2018-10-10 01:14:22 UTC
Works for me.


Note You need to log in before you can comment on or make changes to this bug.