Bug 1614124 - glusterfsd process crashed in a multiplexed configuration during cleanup of a single brick-graph triggered by volume-stop.
Summary: glusterfsd process crashed in a multiplexed configuration during cleanup of a...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Mohit Agrawal
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1608352
TreeView+ depends on / blocked
 
Reported: 2018-08-09 03:06 UTC by Mohit Agrawal
Modified: 2018-10-23 15:16 UTC (History)
12 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1608352
Environment:
Last Closed: 2018-10-23 15:16:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2018-08-09 03:11:24 UTC
REVIEW: https://review.gluster.org/20657 (core: Update condition in get_xlator_by_name_or_type) posted (#3) for review on master by MOHIT AGRAWAL

Comment 2 Worker Ant 2018-08-10 17:48:45 UTC
COMMIT: https://review.gluster.org/20657 committed in master by "Atin Mukherjee" <amukherj@redhat.com> with a commit message- core: Update condition in get_xlator_by_name_or_type

Problem: Sometimes client connection is failed after throwing
         error "cleanup flag is set for xlator Try again later".
         The situation comes only after get a detach request but
         the brick stack is not completely detached and at the same time
         the client initiates a connection with brick

Solution: To resolve the same check cleanup_starting flag in get
          xlator_by_name_or_type, this function call by server_setvolume
          to attach a client with brick.

Change-Id: I3720e42642fe495dd05211e2ed2cb976db9e231b
fixes: bz#1614124
Signed-off-by: Mohit Agrawal <moagrawal@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:16:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.