Bug 161417 - pairing works but there's no file transfer possible
pairing works but there's no file transfer possible
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-23 03:07 EDT by Robert Maessen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 10:44:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
outcome of hcidump (2.88 KB, text/plain)
2005-06-23 03:08 EDT, Robert Maessen
no flags Details
strace of starting sdpd on FC3 (2.40 KB, text/plain)
2005-06-24 07:25 EDT, Robert Maessen
no flags Details
strace of starting sdpd on FC4 (2.64 KB, text/plain)
2005-06-24 07:26 EDT, Robert Maessen
no flags Details
strace /usr/bin/gnome-obex-server (73.17 KB, text/plain)
2005-06-27 09:10 EDT, Robert Maessen
no flags Details

  None (edit)
Description Robert Maessen 2005-06-23 03:07:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
dbus_pin_helper did not work so I changed to /usr/bin/bluepin.
service bluetooth start, hcid doesn't come up so started it by hand, after that pairing works (hcid also stays up after restarting bluetooth).
But it is not possible to transfer files from my cellphone to the computer
Same problem on a FC4 i686 machine, no problem on a FC3 installation on a i686.
After I report this I will send the outcome of hcidump.

Version-Release number of selected component (if applicable):
bluez-utils-2.15-7

How reproducible:
Always

Steps to Reproduce:
1.reboot
2.
3.
  

Actual Results:  hcid did not came up and it failed starting bluetooth

Expected Results:  bluetooth should start up hcid also and file transfers should be possible

Additional info:

Don't know for sure if it is a bluez problem could be a openobex bug also.
Comment 1 Robert Maessen 2005-06-23 03:08:52 EDT
Created attachment 115854 [details]
outcome of hcidump
Comment 2 Robert Maessen 2005-06-24 06:33:47 EDT
sended a file with gnome-obex-send that worked, no problem.
Used sdptool browse, this is the outcome:
Failed to connect to SDP server on 00:12:62:00:E0:CF: 
File descriptor in bad state

Very different from the FC3 sdptool browse, it could browse the cellphone
hcid works as far as I can tell, it just doesn't come up when starting 
bluetooth.
The problem seems to be related to sdpd, don't know that much about bluetooth.
I'll try to find out where the problem is
Comment 3 Robert Maessen 2005-06-24 07:25:37 EDT
Created attachment 115924 [details]
strace of starting sdpd on FC3
Comment 4 Robert Maessen 2005-06-24 07:26:14 EDT
Created attachment 115925 [details]
strace of starting sdpd on FC4
Comment 5 Robert Maessen 2005-06-24 07:28:54 EDT
Did an strace on fc3 and fc4 for the sdp deamon starting no real difference:

FC3 uses a line.
set_thread_area({entry_number:-1 -> 6, base_addr:0xb7e946c0, limit:1048575,
seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0,
useable:1}) = 0

FC4 uses a line.
arch_prctl(ARCH_SET_FS, 0x2aaaaaf0dd00) = 0
Comment 6 Robert Maessen 2005-06-27 08:21:28 EDT
Looks like the problem is in dbus.
I installed dbus from FC3 and bluez-utils, FC4 uses a newer dbus version,
libdbus-1.so.1 in FC4, libdbus-1.so.0 in FC3 almost broke down al the rest but I
could receive files from my cellphone.
Comment 7 Robert Maessen 2005-06-27 09:09:19 EDT
strace gnome-bluetooth-server.
These lines jumped out.

bind(16, {sa_family=AF_BLUETOOTH, sa_data="\0\0\0\0\0\0\4\0\0\0\0\0\0\0"}, 10) =
-1 EADDRINUSE (Address already in use)
close(16)                               = 0
write(2, "\n** (gnome-obex-server:4839): WA"..., 73
** (gnome-obex-server:4839): WARNING **: OBEX server register error: -1
) = 73
write(2, "\n** (gnome-obex-server:4839): WA"..., 75
** (gnome-obex-server:4839): WARNING **: Unable to initialize OBEX source
) = 75
write(2, "\n** (gnome-obex-server:4839): WA"..., 76
** (gnome-obex-server:4839): WARNING **: Couldn't initialise OBEX listener
) = 76
write(12, "\1\v\1\0\1\0\0\0\0\0\0\0=\0\0\0", 16) = 16
close(12)                               = 0
writev(15, [{"GIOP\1\2\1\5\0\0\0\0", 12}], 1) = 12
close(15)                               = 0
writev(13, [{"GIOP\1\2\1\5\0\0\0\0", 12}], 1) = 12
close(13)                               = 0
close(9)                                = 0
close(8)                                = 0
unlink("/tmp/orbit-root/linc-12e7-0-4b707986211fb") = 0
close(14)                               = 0
exit_group(1)                           = ?
Comment 8 Robert Maessen 2005-06-27 09:10:44 EDT
Created attachment 116011 [details]
strace /usr/bin/gnome-obex-server
Comment 9 Robert Maessen 2005-07-01 05:05:31 EDT
I'm not sure if gnome-bluetooth is really the problem.
If I start-up bluetooth it comes up whitout hcid
If I start-up hcid I can make a pairing with hcitool, if however I restart
bluetooth and hcid comes up after that restart I can't make a pairing,
it simply times out.
When I kill the hcid pid and start hcid again apart from bluetooth,
I can pair again.
Comment 10 David Woodhouse 2005-07-01 05:21:59 EDT
We seem to be discussing multiple problems here. The problem with hcid not
starting at boot is probably due to a line in /etc/modprobe.conf which attempts
to load a 'bluez' module for bluetooth support. Remove that line if it exists.

If FC3 'sdptool browse' works and the FC4 one does not, please show hcidump of
_each_ for comparison. sdpd isn't relevant to that.

If your phone is unable (or unwilling) to send files to the PC, try making sure
that the gnome-obex-server is running on the PC before you pair the devices --
you'll need to make the phone forget the PC, then re-pair while
gnome-obex-server is running. Otherwise, it caches the fact that no OBEX service
is available.
Comment 11 Robert Maessen 2005-07-01 05:33:44 EDT
No line about bluez in my /etc/modprobe.conf or it should be one of the aliasas
for the usb-controllers
This is how it looks:

alias eth0 via-velocity
alias scsi_hostadapter sata_via
alias snd-card-0 snd-emu10k1
options snd-card-0 index=0
options snd-emu10k1 index=0
remove snd-emu10k1 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-emu10k1
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias ieee1394-controller ohci1394

I'm quit sure I'd try that approach above but I will try it later on again and
send the outcome of hcidump from 'sdptool browse' for FC3 and FC4.
Comment 12 Joe Acosta 2006-05-21 19:36:55 EDT
I'm using FC4 also.  I just got a bluetooth usb device yesterday and had some
luck transferring files and pairing.  Weee!

First it seems that hcid and sdpd start only if I have my bluetooth device
plugged in.  If it is not then bluetooth wont start them on boot, however after
boot I can restart the service and all is okay.

Second, I have bluez in the modprobe.conf and I've tried this with and without
this in the file and it makes no difference.  

Third, in order to pair, I had to change the /etc/bluetooth/pin file to: 

#! /bin/sh
echo "PIN:xxxx"

where xxxx is my pin and hard coded in the file.  I also had to change
/etc/bluetooth/ fiels rfcomm.conf and hcid.conf so hcid conf uses the script
above instead of the /usr/bin/bluepin.  It was the only way this would work and
its what gentoo's wiki says to do.  So I can now transfer files FROM my phone to
the computer.  I stuggled for several hours yesterday to get pairing to work.

gnome-bluetooth-manager starts but with errors:

/usr/lib/python2.4/site-packages/gnomebt/manager.py:142: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  self.statusbar = gnome.ui.AppBar (gtk.TRUE, gtk.TRUE)
/usr/lib/python2.4/site-packages/gnomebt/manager.py:153: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  self.iconlist.set_sorted (gtk.TRUE)
/usr/lib/python2.4/site-packages/gnomebt/manager.py:162: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  vbox.pack_end (self.scrolly, expand = gtk.TRUE)
/usr/lib/python2.4/site-packages/gnomebt/manager.py:85: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  if self.btctl.is_initialised() == gtk.FALSE:
  
If I hit scan and my phone is off it shows nothing and the scan button only
allows me to scan.  My phone then shows object push and ftp are enabled. 
Eventually after pairing, I see the phone in the list of devices.  I can send
files from my phone to the computer, but not the other way around.

Clicking on properties does nothing.  Really absolutely nothing.   

If I try to run the menu item bluetooth file sharing it does nothing.  Running
gnome-obex-server dies:

1003> gnome-obex-server
** (gnome-obex-server:3354): WARNING **: OBEX server register error: -1
** (gnome-obex-server:3354): WARNING **: Unable to initialize OBEX source
** (gnome-obex-server:3354): WARNING **: Couldn't initialise OBEX listener
 
gnome-obex-send dies also with 

1002> gnome-obex-send
Browsing 00:16:DB:64:D3:A0 ...
Service Name: OPP
Service RecHandle: 0x10004
Protocol Descriptor List:
  "L2CAP" (0x0100)
  "RFCOMM" (0x0003)
    Channel: 5
  "OBEX" (0x0008)
Service Class ID List:
  "OBEX Object Push" (0x1105)
** Message: device 00:16:DB:64:D3:A0 (OBEX Object Push) port 5


I'm getting one way file transfer and sometimes my phone picks up that my
desktop has ftp transfer and othertimes its just object push.








Comment 13 Joe Acosta 2006-05-21 20:14:07 EDT
Okay, found out how to transfer a file.  gnome-obex-send <file> problem is that
the help does not say this is how this work.

 gnome-obex-send --usage
Usage: gnome-obex-send [-?] [-?] [-?] [-?] [-?] [-?] [-?] [-?] [-?|--help]
[--usage] [-d|--dest BDADDR]
        [--gdk-debug=FLAGS] [--gdk-no-debug=FLAGS] [--display=DISPLAY]
        [--screen=SCREEN] [--sync] [--name=NAME] [--class=CLASS]
        [--gtk-debug=FLAGS] [--gtk-no-debug=FLAGS] [--g-fatal-warnings]
        [--gtk-module=MODULE] [--oaf-ior-fd=FD] [--oaf-activate-iid=IID]
        [--oaf-private] [--disable-sound] [--enable-sound]
        [--espeaker=HOSTNAME:PORT] [--version] [--sm-client-id=ID]
        [--sm-config-prefix=PREFIX] [--sm-disable] [--disable-crash-dialog]
        [--load-modules=MODULE1,MODULE2,...]

shouldn't there be a line that says

gnome-obex-send [options]  file

in any case.. works for me
Comment 14 Harald Hoyer 2006-05-31 08:39:08 EDT
btw, gnome-bluetooth-0.7.0-0.FC4.1 was released..
http://www.redhat.com/archives/fedora-test-list/2006-May/msg00152.html
Comment 15 Christian Iseli 2007-01-19 19:22:02 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 16 Ondrej Vasik 2007-10-24 10:44:01 EDT
Closing as works for me as the file transfer is working and no reaction on
needinfo for a long time. Feel free to reopen it on devel branch if it still
occurs on your site.

Note You need to log in before you can comment on or make changes to this bug.