Bug 161428 - extremely slow ethernet network connection
extremely slow ethernet network connection
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-23 07:48 EDT by Jean-Luc Fontaine
Modified: 2015-01-04 17:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 18:10:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (9.36 KB, text/plain)
2005-06-23 07:49 EDT, Jean-Luc Fontaine
no flags Details

  None (edit)
Description Jean-Luc Fontaine 2005-06-23 07:48:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
Using an up-to-date FC4 on a laptop, I am witnessing extremely slow network transfers (using either NFS or CIFS). I tried the latest development 2.6.12 kernel as well: same thing.
Using 2.6.7 from a Knoppix CD fixes the problem.
I took iptables down and tried other fixes from bugzilla searches (tcp_* values in /sys) to no avail.
Please let me know what I should do to help debug the problem (I attached dmesg output just in case). Thanks very much.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. transfer a big file over ethernet
2.
3.
  

Additional info:
Comment 1 Jean-Luc Fontaine 2005-06-23 07:49:09 EDT
Created attachment 115865 [details]
dmesg output
Comment 2 Jean-Luc Fontaine 2005-06-23 11:37:05 EDT
Wait a minute: FTP transfers are fast but it is the network mounts that create
the problem... Actually writing to remote share seems fast but reading a 1MB
file into /dev/zero takes about 2 minutes on NFS, 1 minute on CIFS and 0.25
second on SMBFS!
I am baffled. I'll take any suggestions...
Comment 3 Dave Jones 2005-07-15 17:34:48 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 4 Jean-Luc Fontaine 2005-07-21 04:51:46 EDT
Sorry for the delay, I was out of town.
Unfortunately, 2.6.12-1.1398_FC4 did not solve the problem.
Comment 5 Jean-Luc Fontaine 2005-08-10 10:18:01 EDT
kernel 2.6.12-1.1456_FC5 solves the problem!
Comment 6 Dave Jones 2005-09-30 02:48:28 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 7 Jean-Luc Fontaine 2005-10-03 07:10:01 EDT
Thank you very much Dave for your help.
Unfortunately, I no longer have access to that laptop.
One can only hope that the bug stayed solved, as with 2.6.12-1.1456_FC5 as I
mentioned.
As far as I am concerned, you may close this bug.

Note You need to log in before you can comment on or make changes to this bug.