Bug 161429 - Evolution hangs when accessing MS Exchange 2003 calendar
Evolution hangs when accessing MS Exchange 2003 calendar
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution-connector (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
RHEL4U3NAK
: Desktop
Depends On:
Blocks: 170416
  Show dependency treegraph
 
Reported: 2005-06-23 08:20 EDT by Stuart Campbell
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-21 12:25:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart Campbell 2005-06-23 08:20:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
If I try to access my exchange calendar from evolution it just freezes.  I can access my email on the same server with no problems.

I have updated to Update 1 and still have the same problem.  I have also tried from a number of machines with a fresh install.  

I have tried using the Fedora Core 3 updates for evolution (2.0.4) and this seems to fix the problem.


Version-Release number of selected component (if applicable):
2.0.2

How reproducible:
Always

Steps to Reproduce:
1. Start Evolution
2. Access calendar
3.
  

Actual Results:  Evolution hangs

Expected Results:  Given me access to my calendar

Additional info:
Comment 3 Dave Malcolm 2005-06-23 17:18:31 EDT
Thanks for this report.  

Please can you run:
rpm -q evolution evolution-connector evolution-data-server

on RHEL4, and on the FC3 machine on which it works, and supply the results here,
so that we can be sure what version we're dealing with, and which version works.

Additionally, on the RHEL4 system that exhibits the hang, please can you run the
following in a terminal:

script   (this will create a log called "typescript")
evolution --force-shutdown
export E2K_DEBUG=4
/usr/libexec/evolution/2.0/evolution-exchange-storage &
evolution &

then try to reproduce the hang.  Once this is done, type "exit" in the terminal
to stop logging.  

The "typescript" log file should contain useful information for analysing what's
going on; please can you supply us with a copy.  However it will contain all the
information coming back from the Exchange server, so you may want to email it to
me directly, rather than attaching it to this bug, to protect your privacy.

Thanks.
Comment 4 Stuart Campbell 2005-06-24 05:58:34 EDT
The version numbers are...

RHEL4:
evolution-2.0.2-16
evolution-connector-2.0.2-5
evolution-data-server-1.0.2-7

FC3:
evolution-2.0.4-4
evolution-connector-2.0.4-1
evolution-data-server-1.0.4-3

I will send you the log file directly.
Cheers
Comment 5 Dave Malcolm 2005-06-24 13:57:10 EDT
Thanks for the information and for the log file.

From the log you sent it looks like the evolution-exchange-storage process runs
into difficulties dealing with some of the calendar data received, and
eventually tries to free the same block of memory twice, and is taken down by
glibc's heap protection code; the main evolution process is then stuck, waiting
for a response that never comes.

Please can you run the following:
evolution --force-shutdown
gdb /usr/libexec/evolution/2.0/evolution-exchange-storage
At the gdb prompt type "run" (this is starting the Exchange backend under a
debugger)
Then start Evolution and try to reproduce the hang.  I'd expect to see a message
like:
*** glibc detected *** double free or corruption (out): 0x091f2258 ***
followed by some details, then the gdb prompt.
At the gdb prompt, please type "t a a bt" and attach the resulting text to this bug.

Thanks
Comment 7 Stuart Campbell 2005-06-27 03:16:13 EDT
The message I got was:
*** glibc detected *** double free or corruption (fasttop): 0x0935ab88 ***

Output from debugger:
Thread 2 (Thread -1210405968 (LWP 3888)):
#0  0x0087e7a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00eba404 in poll () from /lib/tls/libc.so.6
#2  0x00c2f163 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#3  0x00c2f47f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#4  0x02370bff in link_thread_io_context () from /usr/lib/libORBit-2.so.0
#5  0x00c841a4 in ?? () from /usr/lib/libglib-2.0.so.0
#6  0xb7daa448 in ?? ()
#7  0x00c47812 in g_static_private_free () from /usr/lib/libglib-2.0.so.0
Previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread -1208149312 (LWP 3885)):
#0  0x0087e7a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00e247d5 in raise () from /lib/tls/libc.so.6
#2  0x00e26149 in abort () from /lib/tls/libc.so.6
#3  0x00e5827a in __libc_message () from /lib/tls/libc.so.6
#4  0x00e5eabf in _int_free () from /lib/tls/libc.so.6
#5  0x00e5ee3a in free () from /lib/tls/libc.so.6
#6  0x00c33cc1 in g_free () from /usr/lib/libglib-2.0.so.0
#7  0x028cae34 in e_cal_component_free_datetime () from /usr/lib/libecal.so.6
#8  0x028d467b in e_cal_listener_stop_notification ()
   from /usr/lib/libecal.so.6
#9  0x02a33f09 in e_cal_backend_sexp_func_time_day_end ()
   from /usr/lib/libedata-cal.so.5
#10 0x0269e7c5 in e_sexp_term_eval () from /usr/lib/libedataserver.so.3
#11 0x0269ef01 in e_sexp_term_eval () from /usr/lib/libedataserver.so.3
#12 0x0269e68f in e_sexp_term_eval () from /usr/lib/libedataserver.so.3
#13 0x0269fc91 in e_sexp_eval () from /usr/lib/libedataserver.so.3
#14 0x02a34d91 in e_cal_backend_sexp_match_comp ()
   from /usr/lib/libedata-cal.so.5
#15 0x080976a5 in e_cal_backend_exchange_add_timezone ()
#16 0x00c23701 in g_hash_table_foreach () from /usr/lib/libglib-2.0.so.0
#17 0x08097ee6 in e_cal_backend_exchange_get_type ()
#18 0x02a3020d in e_cal_backend_start_query () from /usr/lib/libedata-cal.so.5
#19 0x02a3bd65 in e_data_cal_view_get_type () from /usr/lib/libedata-cal.so.5
#20 0x02a2a822 in _ORBIT_skel_small_GNOME_Evolution_Calendar_CalView_start ()
   from /usr/lib/libedata-cal.so.5
#21 0x02367ced in ORBit_POA_setup_root () from /usr/lib/libORBit-2.so.0
#22 0x0236c91f in ORBit_OAObject_invoke () from /usr/lib/libORBit-2.so.0
#23 0x02358f77 in ORBit_small_invoke_adaptor () from /usr/lib/libORBit-2.so.0
#24 0x023680f2 in ORBit_POAObject_post_invoke () from /usr/lib/libORBit-2.so.0
#25 0x02368772 in ORBit_POAObject_post_invoke () from /usr/lib/libORBit-2.so.0
#26 0x023534a1 in giop_thread_queue_process () from /usr/lib/libORBit-2.so.0
#27 0x023536fb in giop_thread_queue_process () from /usr/lib/libORBit-2.so.0
#28 0x023749ff in link_servers_move_io_T () from /usr/lib/libORBit-2.so.0
#29 0x00c2d74b in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#30 0x00c2f1d2 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#31 0x00c2f47f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#32 0x023e1dd5 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#33 0x080761b3 in main ()
Comment 12 Mark Taylor 2006-04-19 02:15:15 EDT
I have the same problem: evolution will hang when I try to access my exchange
server calander.  (on an FC3 system, I can read the calander with no problems)

Any chance this bug will be fixed or evolution will be updated in RHEL4?  

Thanks.
Comment 15 RHEL Product and Program Management 2006-07-21 12:25:48 EDT
Development Management has reviewed and declined this request.  You may appeal this decision by reopening this request.
Comment 16 Chase Stephens 2006-07-21 13:21:18 EDT
(In reply to comment #15)
> Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

So Red Hat will not offer a version of Evolution that works correctly with Exchange?
Comment 17 Stuart Campbell 2006-07-21 16:18:11 EDT
I find this quite worrying, I don't know what the benefits are of running a so
called 'enterprise' linux now.

This basically makes evolution useless for a large number of our users and has
meant that some uses have migrated back to Windows.
Comment 18 Mark Taylor 2006-07-26 00:11:08 EDT
It is disapointing.  I would like to migrate to another distro with a more
modern version of evolution, but only RHEL is aproved where I work.

I gave up on a fix from Redhat many months ago, but I did find a workaround:

get the FC3 RPMS of evolution-*, libsoup and libgal.  Be sure to get the latest
up2date versions, not the versions that come with the FC3 isos.  The RPMs
install with no problems, and they contain a slightly newer version of
evolution-connctor  where this bug was fixed.

  
Comment 19 Stuart Campbell 2006-07-26 04:10:30 EDT
This is exactly what I am doing, I find it strange that RedHat managed to fix
this problem for FC3 but not RHEL4.  I know that they want to keep version
numbers the same but I can't see a major problem going from evolution 2.0.2 to
2.0.4.

Can't wait for RHEL5 which should cure the problem.

Note You need to log in before you can comment on or make changes to this bug.