Bug 1614291 - Allow to configure BlockStorage.ignore-volume-az for Openstack Cloud Provider
Summary: Allow to configure BlockStorage.ignore-volume-az for Openstack Cloud Provider
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.9.z
Assignee: Tzu-Mainn Chen
QA Contact: weiwei jiang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-09 10:26 UTC by Eduardo Minguez
Modified: 2019-06-04 10:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:41 UTC

Description Eduardo Minguez 2018-08-09 10:26:14 UTC
Description of problem:
Add the ignore-volume-az to the cloud.conf for OSP provider for multi-az issues. The code seems to be there in 3.9 https://github.com/openshift/origin/blob/release-3.9/vendor/k8s.io/kubernetes/pkg/cloudprovider/providers/openstack/openstack.go#L99

(not present in 3.7 https://github.com/openshift/origin/blob/release-3.7/vendor/k8s.io/kubernetes/pkg/cloudprovider/providers/openstack/openstack.go#L90-L93)

Version-Release number of the following components:
OCP 3.9 latest or OCP 3.10

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

Additional info:

* Upstream PR - https://github.com/openshift/openshift-ansible/pull/9478
* Code BZ - https://bugzilla.redhat.com/show_bug.cgi?id=1500776
* Related issue - https://bugzilla.redhat.com/show_bug.cgi?id=1594768

Comment 3 Eduardo Minguez 2018-08-10 13:19:37 UTC
I've opened a related bugzilla[1] to add the openshift_cloudprovider_openstack_conf_file variable as well (they are related)

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1614813

Comment 4 Tzu-Mainn Chen 2018-10-31 15:55:20 UTC
It looks like all the related PRs are both merged and backported, so moving to MODIFIED.

Comment 10 errata-xmlrpc 2019-06-04 10:40:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.