This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 16145 - Linux text console pauses on ' character.
Linux text console pauses on ' character.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: console-tools (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-14 01:33 EDT by Edward T. Schlunder
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-14 11:51:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward T. Schlunder 2000-08-14 01:33:14 EDT
No idea which component actually causes this problem, but after installing
Red Hat 7
Beta, if I type a ' (single quote) character, it doesn't show up on the
screen until I hit some other key. If I want to type multiple single quotes
in a row, I can't.

Works fine in X11 terminals, just the Linux text console seems to have this
problem. login prompt, bash prompt, pico, anywhere.
Comment 1 Bernhard Rosenkraenzer 2000-08-14 06:38:01 EDT
This looks like it's intentional (deadkeys feature): When you press ' followed
by e, you should get the accented e character in some keyboard layouts.

Which keyboard layout are you using? Some keyboard layouts have different
keymaps with and without this feature (e.g. there's de-latin1 and
de-latin1-nodeadkeys).
Comment 2 Edward T. Schlunder 2000-08-14 09:27:14 EDT
How do I find out/change the keyboard layout?
Comment 3 Tim Waugh 2000-08-14 11:51:38 EDT
cat /etc/sysconfig/keyboard (or use "setup")

I think "us-latin1" is meant to have deadkeys like that; perhaps you want "us".
Comment 4 Bernhard Rosenkraenzer 2000-08-23 14:35:13 EDT
Closing due to lack of user input
Comment 5 Edward T. Schlunder 2000-08-23 14:44:11 EDT
Sorry. Changing the keyboard layout to us from us-latin1 did indeed fix the
problem, post install. What I was going to do (and never got around to) was
reinstall Red Hat pinstripe and see whether this was sometime I originally
screwed by switching to us-latin1 myself, or if the installer just picked
us-latin1 instead of us for me.

Note You need to log in before you can comment on or make changes to this bug.