Bug 1614512 - ImportError: /usr/lib64/python3.7/site-packages/numpy/core/multiarray.cpython-37m-s390x-linux-gnu.so: undefined symbol: LogBase2_128
Summary: ImportError: /usr/lib64/python3.7/site-packages/numpy/core/multiarray.cpython...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python3-numpy   
(Show other bugs)
Version: 29
Hardware: s390x
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1609532
TreeView+ depends on / blocked
 
Reported: 2018-08-09 18:44 UTC by Jaroslav Škarvada
Modified: 2018-08-23 12:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-08-23 12:48:44 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jaroslav Škarvada 2018-08-09 18:44:53 UTC
Description of problem:
It seems the package is broken on s390x.

Version-Release number of selected component (if applicable):
python3-numpy-1:1.15.0-1.fc29

How reproducible:
Always

Steps to Reproduce:
1. import numpy
2.
3.

Actual results:
  File "/usr/lib64/python3.7/site-packages/numpy/__init__.py", line 142, in <module>
    from . import add_newdocs
  File "/usr/lib64/python3.7/site-packages/numpy/add_newdocs.py", line 13, in <module>
    from numpy.lib import add_newdoc
  File "/usr/lib64/python3.7/site-packages/numpy/lib/__init__.py", line 8, in <module>
    from .type_check import *
  File "/usr/lib64/python3.7/site-packages/numpy/lib/type_check.py", line 11, in <module>
    import numpy.core.numeric as _nx
  File "/usr/lib64/python3.7/site-packages/numpy/core/__init__.py", line 26, in <module>
    raise ImportError(msg)
ImportError: 
Importing the multiarray numpy extension module failed.  Most
likely you are trying to import a failed build of numpy.
If you're working with a numpy git repo, try `git clean -xdf` (removes all
files not under version control).  Otherwise reinstall numpy.
Original error was: /usr/lib64/python3.7/site-packages/numpy/core/multiarray.cpython-37m-s390x-linux-gnu.so: undefined symbol: LogBase2_128

Expected results:
No error

Additional info:
I reproduced it on s390x, but not on x86_64. It's blocking rebuild of urh.

Comment 1 Jaroslav Škarvada 2018-08-10 23:29:30 UTC
It's blocking rebuild of gnuradio.

Comment 2 Jan Kurik 2018-08-14 08:37:45 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 3 Jaroslav Škarvada 2018-08-23 12:48:44 UTC
It seems the problem is gone in both f29 and f30 (probably due to the rebuilt of numpy binding), thus closing.


Note You need to log in before you can comment on or make changes to this bug.