Bug 1614532 - RFE: checkbox or switch to unplug or plug "cable" to network interface.
Summary: RFE: checkbox or switch to unplug or plug "cable" to network interface.
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: All
OS: All
unspecified
low
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
: 1661043 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-09 20:24 UTC by Ivan Baldo
Modified: 2018-12-20 02:02 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-05 19:17:04 UTC


Attachments (Terms of Use)

Description Ivan Baldo 2018-08-09 20:24:12 UTC
Description of problem:
Need to use virsh to disconnect a VM from the network.

Version-Release number of selected component (if applicable): 1.4.0


How reproducible: always


Steps to Reproduce:
1. go to hardware details of a VM.
2. select a NIC.

Actual results:
No button to unplug or plug it, just an option to remove it.


Expected results:
A button or switch or checkbox to unplug or plug the NIC to the network.

Additional info:
https://unix.stackexchange.com/questions/81044/emulate-unplugging-a-network-cable-with-qemu-kvm

Comment 1 Simon Kobyda 2018-08-16 15:42:57 UTC
Patch proposed upstream:
https://www.redhat.com/archives/virt-tools-list/2018-August/msg00024.html

Comment 2 Cole Robinson 2018-09-05 19:17:04 UTC
Patches are upstream now

Comment 3 Jonathan Rubenstein 2018-12-20 02:02:32 UTC
*** Bug 1661043 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.