Bug 16146 - Textutil 2.0e and lack of LC_ALL set.
Summary: Textutil 2.0e and lack of LC_ALL set.
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-14 05:38 UTC by Ben Lindstrom
Modified: 2014-03-17 02:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-14 14:08:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Lindstrom 2000-08-14 05:38:24 UTC
A file containing:
Z
a
A
z
_

sorts in correctly the results are "_,a,z,A,Z" instead of "A,Z,_,a,z".

According to the change log for it.  They require "LC_ALL" to be set 
to "POSIX" before the correct sorting behavior is seen.  A simple changes 
to /etc/profile will work for all tty based processes.  However a 
different solution needs to be present for Crontab to work.

My suggestion?  Fix "textutils" to *DEFAULT* to POSIX, and let LC_ALL 
override it.  Update the info/man to state this change.

Comment 1 Bernhard Rosenkraenzer 2000-08-14 14:08:17 UTC
Guess we should set LC_ALL somewhere in initscripts - hacking textutils for
different defaults would cause confusion and breakages for scripts written to
run on different distributions/OSes.

Comment 2 Bill Nottingham 2000-08-14 14:53:42 UTC
No. We used to set LC_ALL, and it broke other things.

Comment 3 Ben Lindstrom 2000-08-14 15:02:40 UTC
As stated before.  This should be considered a "textutils" bug.  LC_ALL should 
not need to be set anywhere in initscript since it's the incorrect thing to do.





Note You need to log in before you can comment on or make changes to this bug.