Bug 1614662 - ./tests/bugs/replicate/bug-1448804-check-quorum-type-values.t
Summary: ./tests/bugs/replicate/bug-1448804-check-quorum-type-values.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-10 07:28 UTC by Pranith Kumar K
Modified: 2018-10-23 15:16 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-23 15:16:52 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2018-08-10 07:28:52 UTC
Description of problem:
22:05:27 ./tests/bugs/replicate/bug-1448804-check-quorum-type-values.t .. 
22:05:27 1..21
22:05:27 ok 1, LINENUM:6
22:05:27 ok 2, LINENUM:7
22:05:27 ok 3, LINENUM:8
22:05:27 ok 4, LINENUM:9
22:05:27 ok 5, LINENUM:10
22:05:27 ok 6, LINENUM:12
22:05:27 ok 7, LINENUM:16
22:05:27 ok 8, LINENUM:18
22:05:27 ok 9, LINENUM:21
22:05:27 ok 10, LINENUM:22
22:05:27 ok 11, LINENUM:25
22:05:27 ok 12, LINENUM:27
22:05:27 ok 13, LINENUM:30
22:05:27 ok 14, LINENUM:32
22:05:27 ok 15, LINENUM:34
22:05:27 ok 16, LINENUM:37
22:05:27 not ok 17 Got "none" instead of "fixed", LINENUM:38
22:05:27 FAILED COMMAND: fixed echo none
22:05:27 ok 18, LINENUM:39
22:05:27 ok 19, LINENUM:42
22:05:27 ok 20, LINENUM:43
22:05:27 ok 21, LINENUM:45
22:05:27 Failed 1/21 subtests 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-08-10 07:31:17 UTC
REVIEW: https://review.gluster.org/20697 (Make sure EXPECT_WITHIN executes the statement multiple times) posted (#1) for review on master by Pranith Kumar Karampuri

Comment 2 Worker Ant 2018-08-12 08:27:53 UTC
COMMIT: https://review.gluster.org/20697 committed in master by "Atin Mukherjee" <amukherj@redhat.com> with a commit message- Make sure EXPECT_WITHIN executes the statement multiple times

When we pass a command to be executed in EXPECT_WITHIN and we use ``
the value is passed by value, so if the first execution gives a result
that is different from the expected value, EXPECT_WITHIN test will
fail because the command will not be re-evaluated. Changed the
expression with `` to a function. Added sleep(3) in afr.c for
reconfigure to both RC and re-test after the change.

fixes bz#1614662
Change-Id: I3bc8a75b996729261aa48067f6ed8da9c6273b13
Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:16:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.