Bug 1614965 - avc denied message when attempting to get stdout remotely from sanlock
Summary: avc denied message when attempting to get stdout remotely from sanlock
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-10 21:08 UTC by Corey Marthaler
Modified: 2018-10-30 10:09 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.13.1-216.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:08:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:09:18 UTC

Description Corey Marthaler 2018-08-10 21:08:10 UTC
Description of problem:

# I'm unable to grab any stdout remotely from sanlock
[cmarthal@dhcp80-218 bin]$ qarsh root@harding-02 sanlock status
# Getting stderr works fine
[cmarthal@dhcp80-218 bin]$ qarsh root@harding-02 sanlock
Usage:
sanlock <command> <action> ...
[...]


type=AVC msg=audit(1533934462.436:12720): avc:  denied  { connectto } for  pid=16352 comm="sanlock" path="/run/sanlock/sanlock.sock" scontext=system_u:system_r:sanlock_t:s0 tcontext=system_u:system_r:sanlock_t:s0-s0:c0.c1023 tclass=unix_stream_socket permissive=0
type=AVC msg=audit(1533934724.308:12723): avc:  denied  { connectto } for  pid=16782 comm="sanlock" path="/run/sanlock/sanlock.sock" scontext=system_u:system_r:sanlock_t:s0 tcontext=system_u:system_r:sanlock_t:s0-s0:c0.c1023 tclass=unix_stream_socket permissive=0

[root@harding-02 ~]# ausearch -m AVC -ts today | audit2allow


#============= sanlock_t ==============

#!!!! The file '/run/sanlock/sanlock.sock' is mislabeled on your system.  
#!!!! Fix with $ restorecon -R -v /run/sanlock/sanlock.sock
#!!!! This avc can be allowed using the boolean 'daemons_enable_cluster_mode'
allow sanlock_t self:unix_stream_socket connectto;

#!!!! WARNING: 'tmp_t' is a base type.
allow sanlock_t tmp_t:file write;


Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-207.el7.noarch

How reproducible:
Everytime

Comment 4 errata-xmlrpc 2018-10-30 10:08:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.