Bug 1615088 - [RFE] validate CHAP settings before running playbook
Summary: [RFE] validate CHAP settings before running playbook
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.1
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
: 3.2
Assignee: Mike Christie
QA Contact: Manohar Murthy
Bara Ancincova
URL:
Whiteboard:
Depends On: 1566514
Blocks: 1629656
TreeView+ depends on / blocked
 
Reported: 2018-08-12 08:42 UTC by Mike Christie
Modified: 2019-01-03 19:02 UTC (History)
14 users (show)

Fixed In Version: RHEL: ceph-ansible-3.2.0-0.1.beta5.el7cp Ubuntu: ceph-ansible_3.2.0~beta5-2redhat1
Doc Type: Enhancement
Doc Text:
.Ansible now validates CHAP settings before running playbooks Previously, when the Challenge Handshake Authentication Protocol (CHAP) settings were set incorrectly, the `ceph-ansible` utility returned an unclear error message during deploying Ceph iSCSI gateway. With this update, `ceph-ansible` validates the CHAP settings before deploying Ceph iSCSI gateways.
Clone Of: 1566514
Environment:
Last Closed: 2019-01-03 19:01:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ceph ceph-ansible pull 3005 None None None 2018-08-14 23:22:14 UTC
Red Hat Product Errata RHBA-2019:0020 None None None 2019-01-03 19:02:01 UTC

Comment 2 Mike Christie 2018-08-12 08:49:19 UTC
This bz is for a ceph-ansible issue found while testing ceph iscsi no chap support. The problem is the kernel does not support mixing chap and no chap ACLs. For this release we just add a check and fail the setup if the user tries to do this.

Comment 13 errata-xmlrpc 2019-01-03 19:01:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020


Note You need to log in before you can comment on or make changes to this bug.