Bug 161543 - mklibs loops infinitely after using chroot
mklibs loops infinitely after using chroot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
: 161544 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-24 01:16 EDT by Dao
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-24 09:44:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of the make process (254.55 KB, text/plain)
2005-06-24 09:32 EDT, Dao
no flags Details
mklibs file and its output (68.10 KB, text/plain)
2005-06-24 09:37 EDT, Dao
no flags Details
names of directories, files and symbolic links (14.64 MB, text/plain)
2005-06-24 11:34 EDT, Dao
no flags Details

  None (edit)
Description Dao 2005-06-24 01:16:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:

I am building an image base on linux kernel 2.6.7 or later but using linux 7.3 libraries. So I made a tarball with 7.3 libraries and untar on the Fedora Core 3, then chroot to it and build the image. The building process loops infinitely when mklibs reduces the library with the same number of unresolved symbols. 

Using the same tarball on Red Hat 9, go through the same steps to build the image, it works fine. 

I do not know why mklibs can find symbols on FC 3. Is there any difference for chroot or mklibs on Fedora Core 3 and Red Hat 9, or what different environment of the two systems caused the problem?


Version-Release number of selected component (if applicable):
kernel-2.6.7

How reproducible:
Always

Steps to Reproduce:
1. tar development directory tree from Red Hat-7.3
2. untar it on Fedora Core 3 and chroot to it.
3. build image with mklibs to reduce the library.
  

Actual Results:  the process loops endlessly in mklibs with the same number of unsolved symbols.

Expected Results:  mklibs end up with 0 unsolved symbol.



Additional info:

Start Red Hat 9 with kernel 2.6.7, using the same steps, the image built successfully with 0 unresolved symbol.
Comment 1 Tim Waugh 2005-06-24 05:19:08 EDT
*** Bug 161544 has been marked as a duplicate of this bug. ***
Comment 2 Tim Waugh 2005-06-24 05:20:09 EDT
What package does mklibs belong to?
Comment 3 Dao 2005-06-24 09:32:10 EDT
Created attachment 115932 [details]
Output of the make process
Comment 4 Dao 2005-06-24 09:37:25 EDT
Created attachment 115933 [details]
mklibs file and its output

It is a WinZip file.
Comment 5 Dao 2005-06-24 09:39:36 EDT
(In reply to comment #2)
> What package does mklibs belong to?

Please refer to my attachment for mklibs and the output.

Thanks.
Comment 6 Tim Waugh 2005-06-24 09:44:56 EDT
It sounds more like a bug in mklibs than a bug in bash.  Please report your
problem to whoever produces that program.
Comment 7 Dao 2005-06-24 11:34:28 EDT
Created attachment 115936 [details]
names of directories, files and symbolic links

Note You need to log in before you can comment on or make changes to this bug.