Bug 161546 - Alps touchpad/stick unresponsive after S3 suspend/resume
Alps touchpad/stick unresponsive after S3 suspend/resume
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-24 02:17 EDT by Dan Scholnik
Modified: 2015-01-04 17:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-17 15:50:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed fix (421 bytes, patch)
2005-06-24 16:39 EDT, David Moore
no flags Details | Diff

  None (edit)
Description Dan Scholnik 2005-06-24 02:17:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I have a Dell Latitude 
D600 with an "AlpsPS/2 ALPS DualPoint TouchPad", which is a touchpad/eraserhead combo.  When I do an S3 suspend-to-ram and resume, both the touchpad and the stick no longer respond (a USB mouse works fine).  This behavior is the same for kernel-2.6.11-1.1369_FC4 and kernel-2.6.11-1.1381_FC5.  Previously I used a custom-compiled kernel-2.6.10-1.766_FC3 with the alps.patch from the synaptics package applied (and no other changes); this worked great after a suspend/resume.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
1. Suspend-to-RAM (ACPI S3 state)
2. Resume
3. 
  

Actual Results:  No touchpad or stick response.  USB mouse works.

Expected Results:  Touchpad and stick should work as before suspend.

Additional info:

from /var/log/messages under non-working kernel-2.6.11-1.1369_FC4:

Jun 23 15:11:27 hal9000 kernel: alps.c: Enabling hardware tapping
Jun 23 15:11:27 hal9000 kernel: input: DualPoint Stick on isa0060/serio1
Jun 23 15:11:27 hal9000 kernel: input: AlpsPS/2 ALPS DualPoint TouchPad on isa0060/serio1


from /var/log/messages under working custom kernel-2.6.10-1.766_FC3:

Jun 20 21:51:31 hal9000 kernel: alps.c: E6 report: 00 00 64
Jun 20 21:51:31 hal9000 kernel: alps.c: E7 report: 22 02 14
Jun 20 21:51:31 hal9000 kernel: alps.c: E6 report: 00 00 64
Jun 20 21:51:31 hal9000 kernel: alps.c: E7 report: 22 02 14
Jun 20 21:51:31 hal9000 kernel: alps.c: Status: 10 00 64
Jun 20 21:51:31 hal9000 kernel: ALPS Touchpad (Dualpoint) detected
Jun 20 21:51:31 hal9000 kernel:   Disabling hardware tapping
Jun 20 21:51:31 hal9000 kernel: alps.c: Status: 10 00 64
Jun 20 21:51:31 hal9000 kernel: input: AlpsPS/2 ALPS TouchPad on isa0060/serio1
Comment 1 David Moore 2005-06-24 16:39:35 EDT
Created attachment 115953 [details]
Proposed fix

I've got the same bug on my D600.  Here's a patch I whipped up that fixed it
for me.  Looks like there was just a simple typo in some recent changes to the
alps driver.  I'm sending it upstream to the maintainer of the kernel driver
now.
Comment 2 Michael Chan 2005-07-12 16:24:21 EDT
David Moore's fix worked for me with kernel-2.6.12-1.1390_FC4 on a D600

Comment 3 Dave Jones 2005-07-15 17:35:53 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 4 Dan Scholnik 2005-07-19 20:01:54 EDT
No, the problem is still in 2.6.12-1.1398_FC4.
Comment 5 Henrik Nilsson 2005-08-11 09:33:55 EDT
I'm running FC4 with kernel 2.6.12-1.1398_FC4 on a Dell Latitude D600.
With the kernel sources configured according to configs/kernel-2.6.12-i686,
David Moore's patch above to "drivers/input/mouse/alps.c" did NOT work in
isolation for me. However, combining it with the suggested patch to
"drivers/input/serio/serio.c" by David Lowe from follow up to bug #160733
seems to have done the trick. I can suspend and resume, and I have a working
trackpad (and stick) after I resume. However, David Lowe's suggested patch to
"drivers/input/mouse/alps.c" (also from bug #160733) did not work for me.
This patch resulted in a completely non-functional trackpad/stick (immediately
after a boot, before any attempts to suspend).
Comment 6 Matthias Kattanek 2005-08-25 02:30:57 EDT
Running FC4 with kernel 2.6.12-1.1398_FC4 on a Toshiba Tecra M2. 
Mouse pad did not work any longer after suspending once.

Applied David Moore's patch above to "drivers/input/mouse/alps.c" 
(see (a href=https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=160733>bug
#160733 </a> )
only and now the mouse pad and stick work ok after resume. 
there was no need for me to add the serio patch as described by Henrik Nilsson.
Comment 7 Dan Scholnik 2005-08-30 16:53:56 EDT
Just updated to 2.6.12-1.1447_FC4, and now the touchpad/stick don't work at all
in gpm or X, even just after booting.
Comment 8 Dan Scholnik 2005-08-31 06:57:22 EDT
And to update my last comment, after suspending/resuming once, the touchpad and
stick do work.
Comment 9 Dave Jones 2005-09-30 02:51:26 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 10 Dan Scholnik 2005-10-17 15:50:26 EDT
All is well with the stick and pad now, both before and after resume.

Note You need to log in before you can comment on or make changes to this bug.