Bug 16155 - Cannot read 30.7 Gig Hard Drive partition info - UDMA 66 support required?
Cannot read 30.7 Gig Hard Drive partition info - UDMA 66 support required?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-14 06:26 EDT by Dave Green
Modified: 2007-04-18 12:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-08 15:29:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Green 2000-08-14 06:26:40 EDT
I am experiencing problems during the installation of RedHat 6.2 (the same 
problem occurred with 6.1)

RedHat 6.2 cannot access the partition information for my 30.7Gb Hard 
Drive during the install. It says error reading hda partition information. 
Therefore I have to install RH6.2 onto my slower 4.3Gb drive instead. 

I have used the latest install boot disk from the redhat website, but it 
still doesn't work.

However, once RH6.2 is installed on the 4.3Gb drive, it will read and 
write to all my Windows partitions on the 30.7Gb drive with no problems 
what so ever. Its just the install where the problem occurs.

On my 30.7Gb drive I have the following partition sizes:
7993.2 Meg - FAT32 Primary Partition
21312.8 Meg - Extended Primary Partition containing:
12974.3 Meg - FAT32 Logical Partition
7334.3 Meg - FAT32 Logical Partition
1004.0 Meg - FAT32 Logical Partition

Also I have used Partiton Magic 4
Perhaps its the fact I have some partition sizes over 8.4Gb?
Comment 1 Dave Green 2000-08-14 08:19:58 EDT
The problem above that I experience, occurs during the graphical installation, 
before the disk druid screen.

The hard drive I have is a Diamond Maxtor 30.7Gb 7200rpm IDE hard drive (UDMA 
66 capable but running at UDMA 33 due to motherboard).

I have Windows 98 and RH6.2 on the same PC.

Thanking you in anticipation

Dave Green
Comment 2 Matt Wilson 2000-08-14 17:43:06 EDT
udma66 drive are not supported (yet)
Comment 3 Dave Green 2000-08-15 05:38:32 EDT
My question is, does the RH6.2 installer support UDMA 66 hard drives which are 
running in UDMA 33 mode on a UDMA 33 only motherboard?

My UDMA 66 capable 30.7Gb hard drive is connected to a UDMA 33 IDE channel on 
the motherboard (Gigabyte BX2000 which is not capable of UDMA 66).

Therefore the hard drive is effectively functioning as UDMA 33, as my 
motherboard is only UDMA 33. 

Thanks for info above re: UDMA 66 not supported. It could be the reason, as the 
problem has nothing to do with partition sizes >8.4 Gb, as I tried the 
installer with all partitions resized to <8 Gb.
Comment 4 Biju George 2000-10-23 18:59:24 EDT
I have almost the same prob.

Hardware Conf:  pII 300MHz, Abit BE II main board with HPT370 udma controller, Maxtor udma 100 20.4 GB 7200 rpm. 128MB Ram

Setup:
Partition done with partition magic 4.  Have windows 98 on same disk already. Linux 6.2 Installation from CD in full.
HD cable plugged in 3rd slot (should be ide2) which is udma controlled (HPT370)
CD drive in ide0 (Ist slot).

Partition Info:
linux ext2  ~15MB from start ( for /boot)
C:  ~4GB
Extended : rest of the disk which have
D: as first logical
E: as second
Linux ext2 as 3rd (well above 8.4GB limit now)
Linux swap (128 MB)

Symptoms
  1. Installer crashing out after selecting kde/gnome/custom installation.
error :  looks like the harddisk is not detected at all. I went to bash prompt (Alt F2) and did some checks.. 
only the CD Drive (ide0) is present in /proc/..

 1a.  Tried custom and selected the source for packages as the local harddisk ( to see if it detects).
Gave something like 'No harddisk on your system' (not exact words, i dont remember, but same meaning)

I did try these, but no affect.

Tried udma modes 2, 3 , 4 and 4+ using HPT370 configuration. no affect.
Tried cpu bus speed 66 and 100 (softmenu option in Abit mainboard).  no affect.
Tried (tired too) entering boot: command line linux ide2=0x..,0x..,11 .   no affect.  (Did I do it right ?, coz it didnt probe i think)

This worked, which I dont want to.
I plugged the HD cable to ide1 (non udma) and the installer recognised and installed ok.  But I sacrificed the speed alltogather.
Also windows98 gives fatal error at start, since the driver cannot find the drive anymore (HPT370 driver for udma)

Basically I need the installer to detect the harddisk on ide2 which is udma controlled by HPT370 controller.

-Biju
kgb1970@yahoo.com
Comment 5 Michael Fulbright 2001-02-08 15:29:13 EST
This works in the Fisher beta fine.
Comment 6 Brock Organ 2001-02-12 19:05:23 EST
verified these large drives are supported in fisher ...

Note You need to log in before you can comment on or make changes to this bug.