Bug 1615700 - warning shows up after run "Xvfb :99 &"
Summary: warning shows up after run "Xvfb :99 &"
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-xkb-utils
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-14 04:41 UTC by lnie
Modified: 2018-08-14 08:19 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-14 05:51:54 UTC


Attachments (Terms of Use)
journal (144.31 KB, text/x-vhdl)
2018-08-14 04:41 UTC, lnie
no flags Details

Description lnie 2018-08-14 04:41:15 UTC
Created attachment 1475741 [details]
journal

Description of problem:
[lnie@localhost root]$ Xvfb :99 &
[1] 23052
[lnie@localhost root]$ The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Unsupported high keycode 372 for name <I372> ignored
>                   X11 cannot support keycodes above 255.
>                   This warning only shows for the first high keycode.
Errors from xkbcomp are not fatal to the X server


Version-Release number of selected component (if applicable):
xorg-x11-xkb-utils-7.7-27.fc29.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Peter Hutterer 2018-08-14 05:51:54 UTC
yeah, that's fine. we've started adding high keycodes to xkeyboard-config because we can finally handle them on wayland. but the same maps are used under X where we can't - hence the warning. It's just a warning, no functional changes (those keycodes were never available anyway).


Note You need to log in before you can comment on or make changes to this bug.