Bug 1615933 - tmux crash with coredump possibly because of window resize grid_get_cell1 grid.c
Summary: tmux crash with coredump possibly because of window resize grid_get_cell1 grid.c
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tmux
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Filipe Rosset
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-14 14:33 UTC by Phil Smith
Modified: 2018-11-04 22:08 UTC (History)
4 users (show)

Fixed In Version: tmux-2.8-1.fc27 tmux-2.8-1.fc29 tmux-2.8-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-04 02:13:09 UTC


Attachments (Terms of Use)
backtrace (12.69 KB, text/plain)
2018-08-14 14:33 UTC, Phil Smith
no flags Details

Description Phil Smith 2018-08-14 14:33:33 UTC
Created attachment 1475883 [details]
backtrace

Description of problem:
tmux crash in normal use

Version-Release number of selected component (if applicable):
tmux-2.7-1.fc28.x86_64

Fedora release 28 (Twenty Eight)
Linux 4.17.9-200.fc28.x86_64 #1 SMP Mon Jul 23 21:41:29 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
occasional (twice now)

Steps to Reproduce:
1. open xfce4-terminal
2. tmux -2 attach
3. open multiple tabs, multiple edit vim/emacs sessions
4. resize terminal

Actual results:
tmux crash with coredump
 grid_get_cell1 (gl=0x55b77ca4ced0, px=px@entry=0, gc=gc@entry=0x7ffcdc16cc00) at grid.c:421

Expected results:
no crash

Additional info:
bt attached

Comment 1 Phil Smith 2018-09-09 13:00:18 UTC
Reported to tmux. Looks like it was prob ably fixed back in June.
https://github.com/tmux/tmux/issues/1457#issuecomment-417599541
So should be in the next tmux release (2.8).

Comment 2 Fedora Update System 2018-10-19 03:54:16 UTC
tmux-2.8-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cf2819314d

Comment 3 Fedora Update System 2018-10-19 03:54:33 UTC
tmux-2.8-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1c36ae6f6e

Comment 4 Fedora Update System 2018-10-19 03:54:47 UTC
tmux-2.8-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-8c6b526876

Comment 5 Fedora Update System 2018-10-19 16:43:51 UTC
tmux-2.8-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-8c6b526876

Comment 6 Fedora Update System 2018-10-19 16:53:00 UTC
tmux-2.8-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cf2819314d

Comment 7 Fedora Update System 2018-10-20 19:23:46 UTC
tmux-2.8-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1c36ae6f6e

Comment 8 Fedora Update System 2018-11-04 02:13:09 UTC
tmux-2.8-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2018-11-04 06:50:23 UTC
tmux-2.8-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2018-11-04 22:08:07 UTC
tmux-2.8-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.