Bug 1616038 - rt-setup: include enable-netsocket-tstamp-static-key.c
Summary: rt-setup: include enable-netsocket-tstamp-static-key.c
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rt-setup   
(Show other bugs)
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Clark Williams
QA Contact: Jiri Kastner
Marie Dolezelova
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1532680 1616043
TreeView+ depends on / blocked
 
Reported: 2018-08-14 19:10 UTC by Marcelo Tosatti
Modified: 2018-10-30 11:50 UTC (History)
5 users (show)

Fixed In Version: rt-setup-2.0-1.el7
Doc Type: Enhancement
Doc Text:
*rt-entsk* prevents IPI generation and delay of realtime tasks The chrony daemon, *chronyd*, enables or disables network timestamping, which activates a static key within the kernel. When a static key is enabled or disabled, three inter-processor interrupt (IPIs) are generated to notify other processors of the activation. Previously, rapid activation and deactivation of the *chronyd* static keys led to a delay of a realtime task. Consequently, a latency spike occurred. With this update, systemd starts the *rt-entsk* program, which keeps timestamping enabled and prevents the IPIs from being generated. As a result, IPI generation no longer occurs in a rapid succession, and realtime tasks are no longer delayed due to this bug.
Story Points: ---
Clone Of:
: 1619407 (view as bug list)
Environment:
Last Closed: 2018-10-30 11:50:46 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
daemon to enable timestamp on network sockets (969 bytes, text/x-csrc)
2018-08-14 19:12 UTC, Marcelo Tosatti
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3331 None None None 2018-10-30 11:50 UTC

Description Marcelo Tosatti 2018-08-14 19:10:30 UTC
Pei Zhang discovered and Daniel Bristot debugged a problem 
where chronyd enables/disables static keys for network timestamping.

The static key enable/disable process includes several IPIs and this causes
additional latency to -RT systems.

To workaround this particular problem, one can enable timestamping
on a socket separately from chronyd.

This is what the attached enable-netsocket-tstamp-static-key.c does.

Please include it in rt-setup so tuned profile can be patched
to start this daemon.

Comment 2 Marcelo Tosatti 2018-08-14 19:12 UTC
Created attachment 1475947 [details]
daemon to enable timestamp on network sockets

Comment 14 errata-xmlrpc 2018-10-30 11:50:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3331


Note You need to log in before you can comment on or make changes to this bug.