Bug 1616129 - [ovn]ipv6 scope global tentative dadfailed on child interface
Summary: [ovn]ipv6 scope global tentative dadfailed on child interface
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openvswitch2.10
Version: 7.6
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Numan Siddique
QA Contact: haidong li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-15 03:08 UTC by haidong li
Modified: 2019-01-07 08:51 UTC (History)
7 users (show)

Fixed In Version: openvswitch2.10-2.10.0-15.el7fdn
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-07 08:51:12 UTC


Attachments (Terms of Use)
ovnnb_db.db (30.22 KB, text/plain)
2018-09-04 05:59 UTC, haidong li
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0029 None None None 2019-01-07 08:51:23 UTC

Description haidong li 2018-08-15 03:08:16 UTC
Description of problem:
ipv6 scope global tentative dadfailed on child interface 

Version-Release number of selected component (if applicable):
[root@dell-per730-20 ovn]# uname -a
Linux dell-per730-20.rhts.eng.pek2.redhat.com 3.10.0-932.el7.x86_64 #1 SMP Sat Aug 11 08:22:14 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
[root@dell-per730-20 ovn]# rpm -qa | grep openvswitch
openvswitch2.10-2.10.0-0.20180724git1ac6908.el7fdp.x86_64
openvswitch-selinux-extra-policy-1.0-3.el7fdp.noarch
openvswitch2.10-ovn-common-2.10.0-0.20180724git1ac6908.el7fdp.x86_64
openvswitch2.10-ovn-host-2.10.0-0.20180724git1ac6908.el7fdp.x86_64
kernel-kernel-networking-openvswitch-ovn-1.0-100.noarch
openvswitch2.10-ovn-central-2.10.0-0.20180724git1ac6908.el7fdp.x86_64
[root@dell-per730-20 ovn]#

How reproducible:
everytime

Steps to Reproduce:
1.create guests on two machines
2.set up ovn,add the guest to logical switch
3.create logical port whose parent port is the guest's port
4.success to get ipv4 address by dhcp and success to ping
5.failed to get ipv6 address on child interface,configure ipv6 address showed scope global tentative dadfailed 

[root@dell-per730-20 ovn]# ovn-nbctl show
switch 309de3ca-88b0-4a70-94e3-005bd27c9c7e (s2)
    port hv1_vm01_vnet1
        addresses: ["00:de:ad:01:01:01 172.16.102.12 2001:db8:102::12"]
    port vp3
        parent: hv1_vm00_vnet1
        tag: 3
        addresses: ["00:00:00:01:02:03 172.16.102.13 2001:db8:102::13"]
    port hv0_vm00_vnet1
        addresses: ["00:de:ad:00:00:01 172.16.102.21 2001:db8:102::21"]
    port hv0_vm01_vnet1
        addresses: ["00:de:ad:00:01:01 172.16.102.22 2001:db8:102::22"]
    port vp5
        parent: hv1_vm01_vnet1
        tag: 5
        addresses: ["00:00:00:01:02:05 172.16.102.15 2001:db8:102::15"]
    port s2_r1
        type: router
        addresses: ["00:de:ad:ff:01:02 172.16.102.254 2001:db8:102::254"]
    port hv1_vm00_vnet1
        addresses: ["00:de:ad:01:00:01 172.16.102.11 2001:db8:102::11"]
    port vp6
        parent: hv0_vm00_vnet1
        tag: 2
        addresses: ["00:00:00:01:02:06 172.16.102.16 2001:db8:102::16"]
    port vp7
        parent: hv0_vm00_vnet1
        tag: 2
        addresses: ["00:00:00:01:02:07 172.16.102.17 2001:db8:102::17"]
    port vp4
        parent: hv1_vm01_vnet1
        tag: 4
        addresses: ["00:00:00:01:02:04 172.16.102.14 2001:db8:102::14"]
    port vp2
        parent: hv1_vm00_vnet1
        tag: 2
        addresses: ["00:00:00:01:02:02 172.16.102.18 2001:db8:102::18"]
[root@dell-per730-20 ovn]# ovn-sbctl show
Chassis "hv1"
    hostname: "dell-per730-20.rhts.eng.pek2.redhat.com"
    Encap geneve
        ip: "20.0.0.25"
        options: {csum="true"}
    Port_Binding "hv1_vm00_vnet1"
    Port_Binding "vp2"
    Port_Binding "vp5"
    Port_Binding "hv1_vm01_vnet1"
    Port_Binding "vp4"
    Port_Binding "vp3"
Chassis "hv0"
    hostname: "hp-dl385pg8-06.rhts.eng.pek2.redhat.com"
    Encap geneve
        ip: "20.0.0.26"
        options: {csum="true"}
    Port_Binding "hv0_vm01_vnet1"
    Port_Binding "hv0_vm00_vnet1"
    Port_Binding "vp7"
    Port_Binding "vp6"
[root@dell-per730-20 ovn]# 
[root@dell-per730-20 ovn]# virsh list
 Id    Name                           State
----------------------------------------------------
 1     hv1_vm00                       running
 2     hv1_vm01                       running

[root@dell-per730-20 ovn]# virsh console hv1_vm01
Connected to domain hv1_vm01
Escape character is ^]

[root@localhost dhclient]# ip link add link eth1 name vlan4 type vlan id 4 
[root@localhost dhclient]# ip add
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:de:ad:01:01:00 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::2de:adff:fe01:100/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:de:ad:01:01:01 brd ff:ff:ff:ff:ff:ff
    inet6 2001:db8:102::12/64 scope global 
       valid_lft forever preferred_lft forever
6: vlan4@eth1: <BROADCAST,MULTICAST,ALLMULTI,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 00:00:00:01:02:04 brd ff:ff:ff:ff:ff:ff
[root@localhost dhclient]# ping6 2001:db8:102::21
PING 2001:db8:102::21(2001:db8:102::21) 56 data bytes
64 bytes from 2001:db8:102::21: icmp_seq=1 ttl=64 time=2.60 ms

--- 2001:db8:102::21 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 2.601/2.601/2.601/0.000 ms
[root@localhost dhclient]# ip add flush dev eth1
[root@localhost dhclient]# ip add add 2001:db8:102::14/64 dev vlan4
[root@localhost dhclient]# ip add add 172.16.102.14/24 dev vlan4
[root@localhost dhclient]# ping 172.16.102.21
PING 172.16.102.21 (172.16.102.21) 56(84) bytes of data.
64 bytes from 172.16.102.21: icmp_seq=1 ttl=64 time=1.74 ms

--- 172.16.102.21 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 1.749/1.749/1.749/0.000 ms
[root@localhost dhclient]# ping6 2001:db8:102::21
PING 2001:db8:102::21(2001:db8:102::21) 56 data bytes

--- 2001:db8:102::21 ping statistics ---
7 packets transmitted, 0 received, 100% packet loss, time 5999ms

[root@localhost dhclient]# ip add
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:de:ad:01:01:00 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::2de:adff:fe01:100/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:de:ad:01:01:01 brd ff:ff:ff:ff:ff:ff
6: vlan4@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 00:00:00:01:02:04 brd ff:ff:ff:ff:ff:ff
    inet 172.16.102.14/24 brd 172.16.102.255 scope global dynamic vlan4
       valid_lft 2799sec preferred_lft 2799sec
    inet6 2001:db8:102::14/64 scope global tentative dadfailed 
       valid_lft forever preferred_lft forever

[root@localhost dhclient]# 


Actual results:
failed to get ipv6 address by dhcp

Expected results:
success to get ipv6 address by dhcp

Additional info:
This issue happens only when I add child logical interface first.If I configure ipv6 address on vlan4 first,then add the child logical interface with ovn-nbctl command,the ipv6 works well and success to ping.

Comment 2 Numan Siddique 2018-09-03 12:30:47 UTC
I am a little bit confused. Is it possible to share the dump of whole ovn nb db ?

Also have you added a logical router ? and configured ipv6 params like address_mode, etc in the logical router port ?

If you have a script to run the tests locally can you please share ?

Thanks

Comment 3 haidong li 2018-09-04 05:59:22 UTC
Created attachment 1480673 [details]
ovnnb_db.db


I have attached the ovnnb_db.db here.I haven't added a logical router,only used logical switch,and set the address like this:
ovn-nbctl lsp-add s2 vp2 hv1_vm00_vnet1 2 -- lsp-set-addresses vp2 "$mac_v2 $ip_v2 $ip6_v2"

The path of case is listed below,the test function is "ovn_test_tags".The test scripts for ipv6 in this function are commented out,I have to remove comment before I test it:
http://pkgs.devel.redhat.com/cgit/tests/kernel/tree/networking/openvswitch/ovn/runtest.sh 

You can login the two machines for check with root/redhat if necessary:
dell-per730-57.rhts.eng.pek2.redhat.com
dell-per730-19.rhts.eng.pek2.redhat.com

Comment 4 Numan Siddique 2018-09-04 10:54:38 UTC
Thanks. I am able to reproduce the issue locally.

Comment 5 Numan Siddique 2018-09-04 16:32:24 UTC
Below are my observations.

I did my testing first on Centos 7 with the kernel - 3.10.0-862.11.6.el7.x86_64
For my testing I used the below child logical port

port vp4
        parent: hv1_vm01_vnet1
        tag: 4
        addresses: ["00:00:00:01:02:04 172.16.102.14 2001:db8:102::14"]


As soon as the vlan interface is brought up, we see the below dmesg
---
[  138.000753] IPv6: vlan4: IPv6 duplicate address fe80::200:ff:fe01:204 detected!
---

Because of this DAD issue, the IPv6 traffic is getting dropped by the guest kernel and the IPv6 DHCPv6 packet is never received by vswitchd.

If I bring the vlan4-  interface first and then add the child logical interface, The link local address gets configured properly without any DAD issue. But when I run dhclient -6 -v vlan4, I still see the DAD issue for the IPv6 address - 2001:db8:102::14.

Then I updated my kernel to 4.18.5-1.el7.elrepo.x86_64 (from the kernel-ml repo) and I don't see the issue. I also don't see the issue on my fedora laptop running - 4.17.14-202.fc28.x86_64

Looks to me its a kernel issue. Probably rhel/centos kernel needs some backports.

Although this issue is seen only with OVN managed interfaces. If I add a vlan interface on eth1 for example, I don't see the DAD issue. Not really sure what's happening. But definitely not an OVN issue.

Below is the output on latest kernel
*****************

[root@vm3 vagrant]# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 52:54:00:fb:7b:d2 brd ff:ff:ff:ff:ff:ff
    inet 192.168.121.213/24 brd 192.168.121.255 scope global dynamic eth0
       valid_lft 3376sec preferred_lft 3376sec
    inet6 fe80::5054:ff:fefb:7bd2/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 52:54:00:1b:7b:d2 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5054:ff:fe1b:7bd2/64 scope link 
       valid_lft forever preferred_lft forever
8: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:de:ad:01:01:01 brd ff:ff:ff:ff:ff:ff
    inet 172.16.102.12/24 brd 172.16.102.255 scope global dynamic eth2
       valid_lft 3590sec preferred_lft 3590sec
    inet6 2001:db8:102::12/64 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::2de:adff:fe01:101/64 scope link 
       valid_lft forever preferred_lft forever
[root@vm3 vagrant]# dmesg
[root@vm3 vagrant]# vi setup_ovn_vlan.sh
[root@vm3 vagrant]# chmod 0755 setup_ovn_vlan.sh
[root@vm3 vagrant]# cat setup_ovn_vlan.sh 
ip link add link eth2  name vlan4 type vlan id 4
ip netns add ns4
ip link set vlan4 netns ns4
ip netns exec ns4 ip link set vlan4 down
ip netns exec ns4 ip link set vlan4 address 00:00:00:01:02:04
ip netns exec ns4 ip link set vlan4 up

[root@vm3 vagrant]# ./setup_ovn_vlan.sh 
[root@vm3 vagrant]# dmesg
[  264.773862] 8021q: 802.1Q VLAN Support v1.8
[  264.773879] 8021q: adding VLAN 0 to HW filter on device eth0
[  264.773983] 8021q: adding VLAN 0 to HW filter on device eth1
[  264.774044] 8021q: adding VLAN 0 to HW filter on device eth2
[root@vm3 vagrant]# dmesg -c
[  264.773862] 8021q: 802.1Q VLAN Support v1.8
[  264.773879] 8021q: adding VLAN 0 to HW filter on device eth0
[  264.773983] 8021q: adding VLAN 0 to HW filter on device eth1
[  264.774044] 8021q: adding VLAN 0 to HW filter on device eth2

[root@vm3 vagrant]# ip netns
ns4 (id: 0)
[root@vm3 vagrant]# ip netns exec ns4 ip a
1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
9: vlan4@if8: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 00:00:00:01:02:04 brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet6 fe80::200:ff:fe01:204/64 scope link 
       valid_lft forever preferred_lft forever
[root@vm3 vagrant]# ip netns exec ns4 dhclient -6 -d vlan4
Internet Systems Consortium DHCP Client 4.2.5
Copyright 2004-2013 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

/var/lib/dhclient/dhclient6.leases line 3: Unknown interface.
  interface "eth2"
             ^
/var/lib/dhclient/dhclient6.leases line 17: Lease has no interface designation.
}
 ^
/var/lib/dhclient/dhclient6.leases line 17: No matching client state.
}
 ^
Listening on Socket/vlan4
Sending on   Socket/vlan4
PRC: Soliciting for leases (INIT).
XMT: Forming Solicit, 0 ms elapsed.
XMT:  X-- IA_NA 00:01:02:04
XMT:  | X-- Request renew in  +3600
XMT:  | X-- Request rebind in +5400
XMT: Solicit on vlan4, interval 1040ms.
RCV: Advertise message on vlan4 from fe80::2de:adff:feff:102.
RCV:  X-- IA_NA 00:01:02:04
RCV:  | X-- starts 1536077015
RCV:  | X-- t1 - renew  +4294967295
RCV:  | X-- t2 - rebind +4294967295
RCV:  | X-- [Options]
RCV:  | | X-- IAADDR 2001:db8:102::14
RCV:  | | | X-- Preferred lifetime 4294967295.
RCV:  | | | X-- Max lifetime 4294967295.
RCV:  X-- Server ID: 00:03:00:01:00:de:ad:ff:01:02
RCV:  Advertisement recorded.
PRC: Selecting best advertised lease.
PRC: Considering best lease.
PRC:  X-- Initial candidate 00:03:00:01:00:de:ad:ff:01:02 (s: 154, p: 0).
XMT: Forming Request, 0 ms elapsed.
XMT:  X-- IA_NA 00:01:02:04
XMT:  | X-- Requested renew  +3600
XMT:  | X-- Requested rebind +5400
XMT:  | | X-- IAADDR 2001:db8:102::14
XMT:  | | | X-- Preferred lifetime +7200
XMT:  | | | X-- Max lifetime +7500
XMT:  V IA_NA appended.
XMT: Request on vlan4, interval 1090ms.
RCV: Reply message on vlan4 from fe80::2de:adff:feff:102.
RCV:  X-- IA_NA 00:01:02:04
RCV:  | X-- starts 1536077016
RCV:  | X-- t1 - renew  +4294967295
RCV:  | X-- t2 - rebind +4294967295
RCV:  | X-- [Options]
RCV:  | | X-- IAADDR 2001:db8:102::14
RCV:  | | | X-- Preferred lifetime 4294967295.
RCV:  | | | X-- Max lifetime 4294967295.
RCV:  X-- Server ID: 00:03:00:01:00:de:ad:ff:01:02
PRC: Bound to lease 00:03:00:01:00:de:ad:ff:01:02.
^C
[root@vm3 vagrant]# dmesg
[root@vm3 vagrant]# uname -a
Linux vm3 4.18.5-1.el7.elrepo.x86_64 #1 SMP Fri Aug 24 11:35:05 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
[root@vm3 vagrant]# ip netns
ns4 (id: 0)
[root@vm3 vagrant]# ip netns exec ns4 ip a
1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
9: vlan4@if8: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 00:00:00:01:02:04 brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet6 2001:db8:102::14/64 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::200:ff:fe01:204/64 scope link 
       valid_lft forever preferred_lft forever
****************

Comment 6 Numan Siddique 2018-09-06 09:05:01 UTC
I will check for the required patches to be back ported.

Comment 8 Numan Siddique 2018-09-17 09:25:53 UTC
Submitted the patch to fix the issue in OVN - https://patchwork.ozlabs.org/patch/970470/

Comment 12 haidong li 2018-11-21 09:09:02 UTC
Hi Numan,I have tested on the latest version of ovn. At first,the interface is still displayed as "tentative dadfailed".But after I set it down and up,it become normal and success to get ipv6 address and ping out.I don't know what the reason is,is it related to the kernel version of guest?

[root@localhost ~]# uname -a
Linux localhost.localdomain 3.10.0-931.el7.x86_64 #1 SMP Tue Jul 31 17:55:24 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
[root@localhost ~]# 
[root@dell-per730-19 ovn]# uname -a
Linux dell-per730-19.rhts.eng.pek2.redhat.com 3.10.0-957.el7.x86_64 #1 SMP Thu Oct 4 20:48:51 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
[root@dell-per730-19 ovn]# rpm -qa | grep openvswitch
kernel-kernel-networking-openvswitch-ovn-1.0-108.noarch
openvswitch2.10-ovn-central-2.10.0-28.el7fdp.x86_64
openvswitch-selinux-extra-policy-1.0-8.el7fdp.noarch
openvswitch2.10-ovn-common-2.10.0-28.el7fdp.x86_64
openvswitch2.10-ovn-host-2.10.0-28.el7fdp.x86_64
openvswitch2.10-2.10.0-28.el7fdp.x86_64
[root@dell-per730-19 ovn]#
[root@dell-per730-19 ovn]# virsh console hv1_vm01
Connected to domain hv1_vm01
Escape character is ^]

[root@localhost ~]# ip netns exec ns4 ip add
1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
4: vlan4@if3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 00:00:00:01:02:04 brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet 172.16.102.14/24 brd 172.16.102.255 scope global dynamic vlan4
       valid_lft 31sec preferred_lft 31sec
    inet6 fe80::2de:adff:fe01:101/64 scope link tentative dadfailed 
       valid_lft forever preferred_lft forever
[root@localhost ~]# ip netns exec ns4 ip link set vlan4 down
[root@localhost ~]# ip netns exec ns4 ip link set vlan4 up
[root@localhost ~]# ip netns exec ns4 ip add
1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
4: vlan4@if3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 00:00:00:01:02:04 brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet 172.16.102.14/24 brd 172.16.102.255 scope global dynamic vlan4
       valid_lft 1sec preferred_lft 1sec
    inet6 fe80::200:ff:fe01:204/64 scope link 
       valid_lft forever preferred_lft forever
[root@localhost ~]# ip netns exec ns4 dhclient -6 -v vlan4
Internet Systems Consortium DHCP Client 4.2.5
Copyright 2004-2013 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on Socket/vlan4
Sending on   Socket/vlan4
PRC: Soliciting for leases (INIT).
XMT: Forming Solicit, 0 ms elapsed.
XMT:  X-- IA_NA 00:01:02:04
XMT:  | X-- Request renew in  +3600
XMT:  | X-- Request rebind in +5400
XMT: Solicit on vlan4, interval 1060ms.
RCV: Advertise message on vlan4 from fe80::2de:adff:feff:102.
RCV:  X-- IA_NA 00:01:02:04
RCV:  | X-- starts 1542789361
RCV:  | X-- t1 - renew  +4294967295
RCV:  | X-- t2 - rebind +4294967295
RCV:  | X-- [Options]
RCV:  | | X-- IAADDR 2001:db8:102::14
RCV:  | | | X-- Preferred lifetime 4294967295.
RCV:  | | | X-- Max lifetime 4294967295.
RCV:  X-- Server ID: 00:03:00:01:00:de:ad:ff:01:02
RCV:  Advertisement recorded.
PRC: Selecting best advertised lease.
PRC: Considering best lease.
PRC:  X-- Initial candidate 00:03:00:01:00:de:ad:ff:01:02 (s: 154, p: 0).
XMT: Forming Request, 0 ms elapsed.
XMT:  X-- IA_NA 00:01:02:04
XMT:  | X-- Requested renew  +3600
XMT:  | X-- Requested rebind +5400
XMT:  | | X-- IAADDR 2001:db8:102::14
XMT:  | | | X-- Preferred lifetime +7200
XMT:  | | | X-- Max lifetime +7500
XMT:  V IA_NA appended.
XMT: Request on vlan4, interval 1030ms.
RCV: Reply message on vlan4 from fe80::2de:adff:feff:102.
RCV:  X-- IA_NA 00:01:02:04
RCV:  | X-- starts 1542789362
RCV:  | X-- t1 - renew  +4294967295
RCV:  | X-- t2 - rebind +4294967295
RCV:  | X-- [Options]
RCV:  | | X-- IAADDR 2001:db8:102::14
RCV:  | | | X-- Preferred lifetime 4294967295.
RCV:  | | | X-- Max lifetime 4294967295.
RCV:  X-- Server ID: 00:03:00:01:00:de:ad:ff:01:02
PRC: Bound to lease 00:03:00:01:00:de:ad:ff:01:02.
[root@localhost ~]#

[root@localhost ~]# ip netns exec ns4 ip add
1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
4: vlan4@if3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 00:00:00:01:02:04 brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet6 2001:db8:102::14/64 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::200:ff:fe01:204/64 scope link 
       valid_lft forever preferred_lft forever
[root@localhost ~]#

Comment 13 Numan Siddique 2018-11-22 11:06:54 UTC
(In reply to haidong li from comment #12)
> Hi Numan,I have tested on the latest version of ovn. At first,the interface
> is still displayed as "tentative dadfailed".But after I set it down and
> up,it become normal and success to get ipv6 address and ping out.I don't
> know what the reason is,is it related to the kernel version of guest?
> 
> [root@localhost ~]# uname -a
> Linux localhost.localdomain 3.10.0-931.el7.x86_64 #1 SMP Tue Jul 31 17:55:24
> EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
> [root@localhost ~]# 
> [root@dell-per730-19 ovn]# uname -a
> Linux dell-per730-19.rhts.eng.pek2.redhat.com 3.10.0-957.el7.x86_64 #1 SMP
> Thu Oct 4 20:48:51 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
> [root@dell-per730-19 ovn]# rpm -qa | grep openvswitch
> kernel-kernel-networking-openvswitch-ovn-1.0-108.noarch
> openvswitch2.10-ovn-central-2.10.0-28.el7fdp.x86_64
> openvswitch-selinux-extra-policy-1.0-8.el7fdp.noarch
> openvswitch2.10-ovn-common-2.10.0-28.el7fdp.x86_64
> openvswitch2.10-ovn-host-2.10.0-28.el7fdp.x86_64
> openvswitch2.10-2.10.0-28.el7fdp.x86_64
> [root@dell-per730-19 ovn]#
> [root@dell-per730-19 ovn]# virsh console hv1_vm01
> Connected to domain hv1_vm01
> Escape character is ^]
> 
> [root@localhost ~]# ip netns exec ns4 ip add
> 1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN group default qlen 1000
>     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
> 4: vlan4@if3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state
> UP group default qlen 1000
>     link/ether 00:00:00:01:02:04 brd ff:ff:ff:ff:ff:ff link-netnsid 0
>     inet 172.16.102.14/24 brd 172.16.102.255 scope global dynamic vlan4
>        valid_lft 31sec preferred_lft 31sec
>     inet6 fe80::2de:adff:fe01:101/64 scope link tentative dadfailed 
>        valid_lft forever preferred_lft forever
> [root@localhost ~]# ip netns exec ns4 ip link set vlan4 down
> [root@localhost ~]# ip netns exec ns4 ip link set vlan4 up
> [root@localhost ~]# ip netns exec ns4 ip add
> 1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN group default qlen 1000
>     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
> 4: vlan4@if3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state
> UP group default qlen 1000
>     link/ether 00:00:00:01:02:04 brd ff:ff:ff:ff:ff:ff link-netnsid 0
>     inet 172.16.102.14/24 brd 172.16.102.255 scope global dynamic vlan4
>        valid_lft 1sec preferred_lft 1sec
>     inet6 fe80::200:ff:fe01:204/64 scope link 
>        valid_lft forever preferred_lft forever
> [root@localhost ~]# ip netns exec ns4 dhclient -6 -v vlan4
> Internet Systems Consortium DHCP Client 4.2.5
> Copyright 2004-2013 Internet Systems Consortium.
> All rights reserved.
> For info, please visit https://www.isc.org/software/dhcp/
> 
> Listening on Socket/vlan4
> Sending on   Socket/vlan4
> PRC: Soliciting for leases (INIT).
> XMT: Forming Solicit, 0 ms elapsed.
> XMT:  X-- IA_NA 00:01:02:04
> XMT:  | X-- Request renew in  +3600
> XMT:  | X-- Request rebind in +5400
> XMT: Solicit on vlan4, interval 1060ms.
> RCV: Advertise message on vlan4 from fe80::2de:adff:feff:102.
> RCV:  X-- IA_NA 00:01:02:04
> RCV:  | X-- starts 1542789361
> RCV:  | X-- t1 - renew  +4294967295
> RCV:  | X-- t2 - rebind +4294967295
> RCV:  | X-- [Options]
> RCV:  | | X-- IAADDR 2001:db8:102::14
> RCV:  | | | X-- Preferred lifetime 4294967295.
> RCV:  | | | X-- Max lifetime 4294967295.
> RCV:  X-- Server ID: 00:03:00:01:00:de:ad:ff:01:02
> RCV:  Advertisement recorded.
> PRC: Selecting best advertised lease.
> PRC: Considering best lease.
> PRC:  X-- Initial candidate 00:03:00:01:00:de:ad:ff:01:02 (s: 154, p: 0).
> XMT: Forming Request, 0 ms elapsed.
> XMT:  X-- IA_NA 00:01:02:04
> XMT:  | X-- Requested renew  +3600
> XMT:  | X-- Requested rebind +5400
> XMT:  | | X-- IAADDR 2001:db8:102::14
> XMT:  | | | X-- Preferred lifetime +7200
> XMT:  | | | X-- Max lifetime +7500
> XMT:  V IA_NA appended.
> XMT: Request on vlan4, interval 1030ms.
> RCV: Reply message on vlan4 from fe80::2de:adff:feff:102.
> RCV:  X-- IA_NA 00:01:02:04
> RCV:  | X-- starts 1542789362
> RCV:  | X-- t1 - renew  +4294967295
> RCV:  | X-- t2 - rebind +4294967295
> RCV:  | X-- [Options]
> RCV:  | | X-- IAADDR 2001:db8:102::14
> RCV:  | | | X-- Preferred lifetime 4294967295.
> RCV:  | | | X-- Max lifetime 4294967295.
> RCV:  X-- Server ID: 00:03:00:01:00:de:ad:ff:01:02
> PRC: Bound to lease 00:03:00:01:00:de:ad:ff:01:02.
> [root@localhost ~]#
> 
> [root@localhost ~]# ip netns exec ns4 ip add
> 1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN group default qlen 1000
>     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
> 4: vlan4@if3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state
> UP group default qlen 1000
>     link/ether 00:00:00:01:02:04 brd ff:ff:ff:ff:ff:ff link-netnsid 0
>     inet6 2001:db8:102::14/64 scope global 
>        valid_lft forever preferred_lft forever
>     inet6 fe80::200:ff:fe01:204/64 scope link 
>        valid_lft forever preferred_lft forever
> [root@localhost ~]#

Hi,
Let me test it out and come back to you.

Comment 14 Numan Siddique 2018-11-22 12:27:52 UTC
Hi Haidong li,

I tested with my setup with master ovs/ovn and it is working as expected.
I logged into your machine - dell-per730-19.rhts.eng.pek2.redhat.com
and I see that the version of openvswitch/ovn used is 

root@dell-per730-19 ~]# rpm -qa | grep openvswitch
kernel-kernel-networking-openvswitch-ovs_qinq-1.3-29.noarch
kernel-kernel-networking-openvswitch-ovn-1.0-108.noarch
openvswitch-ovn-host-2.9.0-81.el7fdp.x86_64
openvswitch-selinux-extra-policy-1.0-8.el7fdp.noarch
openvswitch-2.9.0-81.el7fdp.x86_64
openvswitch-ovn-central-2.9.0-81.el7fdp.x86_64
openvswitch-ovn-common-2.9.0-81.el7fdp.x86_64

Looks like you have changed your setup. That's fine.

Please see below for a couple of comments


(In reply to Numan Siddique from comment #13)
> (In reply to haidong li from comment #12)
> > Hi Numan,I have tested on the latest version of ovn. At first,the interface
> > is still displayed as "tentative dadfailed".But after I set it down and
> > up,it become normal and success to get ipv6 address and ping out.I don't
> > know what the reason is,is it related to the kernel version of guest?
> > 
> > [root@localhost ~]# uname -a
> > Linux localhost.localdomain 3.10.0-931.el7.x86_64 #1 SMP Tue Jul 31 17:55:24
> > EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
> > [root@localhost ~]# 
> > [root@dell-per730-19 ovn]# uname -a
> > Linux dell-per730-19.rhts.eng.pek2.redhat.com 3.10.0-957.el7.x86_64 #1 SMP
> > Thu Oct 4 20:48:51 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
> > [root@dell-per730-19 ovn]# rpm -qa | grep openvswitch
> > kernel-kernel-networking-openvswitch-ovn-1.0-108.noarch
> > openvswitch2.10-ovn-central-2.10.0-28.el7fdp.x86_64
> > openvswitch-selinux-extra-policy-1.0-8.el7fdp.noarch
> > openvswitch2.10-ovn-common-2.10.0-28.el7fdp.x86_64
> > openvswitch2.10-ovn-host-2.10.0-28.el7fdp.x86_64
> > openvswitch2.10-2.10.0-28.el7fdp.x86_64
> > [root@dell-per730-19 ovn]#
> > [root@dell-per730-19 ovn]# virsh console hv1_vm01
> > Connected to domain hv1_vm01
> > Escape character is ^]
> > 
> > [root@localhost ~]# ip netns exec ns4 ip add
> > 1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN group default qlen 1000
> >     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
> > 4: vlan4@if3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state
> > UP group default qlen 1000
> >     link/ether 00:00:00:01:02:04 brd ff:ff:ff:ff:ff:ff link-netnsid 0
> >     inet 172.16.102.14/24 brd 172.16.102.255 scope global dynamic vlan4
> >        valid_lft 31sec preferred_lft 31sec
> >     inet6 fe80::2de:adff:fe01:101/64 scope link tentative dadfailed 
> >        valid_lft forever preferred_lft forever


Looks to me the vlan4 interface when created had the mac address of eth1 and that's why you see "inet6 fe80::2de:adff:fe01:101/64" which is also the IPv6 LLA of eth1.

Can you please test it out this way manually once ?

***
dmesg -c
#!/bin/bash

ip link add link eth1  name vlan4 type vlan id 4
ip netns add ns4
ip link set vlan4 netns ns4
ip netns exec ns4 ip link set vlan4 down
ip netns exec ns4 ip link set vlan4 address 00:00:00:01:02:04
ip netns exec ns4 ip link set vlan4 up

*****

Thanks


> > [root@localhost ~]# ip netns exec ns4 ip link set vlan4 down
> > [root@localhost ~]# ip netns exec ns4 ip link set vlan4 up
> > [root@localhost ~]# ip netns exec ns4 ip add
> > 1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN group default qlen 1000
> >     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
> > 4: vlan4@if3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state
> > UP group default qlen 1000
> >     link/ether 00:00:00:01:02:04 brd ff:ff:ff:ff:ff:ff link-netnsid 0
> >     inet 172.16.102.14/24 brd 172.16.102.255 scope global dynamic vlan4
> >        valid_lft 1sec preferred_lft 1sec
> >     inet6 fe80::200:ff:fe01:204/64 scope link 
> >        valid_lft forever preferred_lft forever
> > [root@localhost ~]# ip netns exec ns4 dhclient -6 -v vlan4
> > Internet Systems Consortium DHCP Client 4.2.5
> > Copyright 2004-2013 Internet Systems Consortium.
> > All rights reserved.
> > For info, please visit https://www.isc.org/software/dhcp/
> > 
> > Listening on Socket/vlan4
> > Sending on   Socket/vlan4
> > PRC: Soliciting for leases (INIT).
> > XMT: Forming Solicit, 0 ms elapsed.
> > XMT:  X-- IA_NA 00:01:02:04
> > XMT:  | X-- Request renew in  +3600
> > XMT:  | X-- Request rebind in +5400
> > XMT: Solicit on vlan4, interval 1060ms.
> > RCV: Advertise message on vlan4 from fe80::2de:adff:feff:102.
> > RCV:  X-- IA_NA 00:01:02:04
> > RCV:  | X-- starts 1542789361
> > RCV:  | X-- t1 - renew  +4294967295
> > RCV:  | X-- t2 - rebind +4294967295
> > RCV:  | X-- [Options]
> > RCV:  | | X-- IAADDR 2001:db8:102::14
> > RCV:  | | | X-- Preferred lifetime 4294967295.
> > RCV:  | | | X-- Max lifetime 4294967295.
> > RCV:  X-- Server ID: 00:03:00:01:00:de:ad:ff:01:02
> > RCV:  Advertisement recorded.
> > PRC: Selecting best advertised lease.
> > PRC: Considering best lease.
> > PRC:  X-- Initial candidate 00:03:00:01:00:de:ad:ff:01:02 (s: 154, p: 0).
> > XMT: Forming Request, 0 ms elapsed.
> > XMT:  X-- IA_NA 00:01:02:04
> > XMT:  | X-- Requested renew  +3600
> > XMT:  | X-- Requested rebind +5400
> > XMT:  | | X-- IAADDR 2001:db8:102::14
> > XMT:  | | | X-- Preferred lifetime +7200
> > XMT:  | | | X-- Max lifetime +7500
> > XMT:  V IA_NA appended.
> > XMT: Request on vlan4, interval 1030ms.
> > RCV: Reply message on vlan4 from fe80::2de:adff:feff:102.
> > RCV:  X-- IA_NA 00:01:02:04
> > RCV:  | X-- starts 1542789362
> > RCV:  | X-- t1 - renew  +4294967295
> > RCV:  | X-- t2 - rebind +4294967295
> > RCV:  | X-- [Options]
> > RCV:  | | X-- IAADDR 2001:db8:102::14
> > RCV:  | | | X-- Preferred lifetime 4294967295.
> > RCV:  | | | X-- Max lifetime 4294967295.
> > RCV:  X-- Server ID: 00:03:00:01:00:de:ad:ff:01:02
> > PRC: Bound to lease 00:03:00:01:00:de:ad:ff:01:02.
> > [root@localhost ~]#
> > 
> > [root@localhost ~]# ip netns exec ns4 ip add
> > 1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN group default qlen 1000
> >     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
> > 4: vlan4@if3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state
> > UP group default qlen 1000
> >     link/ether 00:00:00:01:02:04 brd ff:ff:ff:ff:ff:ff link-netnsid 0
> >     inet6 2001:db8:102::14/64 scope global 
> >        valid_lft forever preferred_lft forever
> >     inet6 fe80::200:ff:fe01:204/64 scope link 
> >        valid_lft forever preferred_lft forever
> > [root@localhost ~]#
> 
> Hi,
> Let me test it out and come back to you.

Comment 15 haidong li 2018-11-23 10:17:26 UTC
Hi Numan,I have changed the version of ovs packet to 2.10.0-28. It make me confused that the other machine dell-per730-57.rhts.eng.pek2.redhat.com works well with the ovn-controller.But the machine dell-per730-19.rhts.eng.pek2.redhat.com which have ovn-northd and ovn-controller in it,still have some issue on the ipv6.After I configure "systemctl restart ovn-controller" ,it become normal.Can you please login the machine and check again? Thanks a lot!

[root@dell-per730-19 ~]# virsh console hv1_vm00
Connected to domain hv1_vm00
Escape character is ^]

[root@localhost ~]# ip netns exec ns2 ip add
1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
4: vlan2@if3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 00:00:00:01:02:02 brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet 172.16.102.18/24 brd 172.16.102.255 scope global dynamic vlan2
       valid_lft 2504sec preferred_lft 2504sec
    inet6 fe80::200:ff:fe01:202/64 scope link 
       valid_lft forever preferred_lft forever
[root@localhost ~]# ip netns exec ns2 dhclient -6 -v vlan2
Internet Systems Consortium DHCP Client 4.2.5
Copyright 2004-2013 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

/var/lib/dhclient/dhclient6.leases line 3: Unknown interface.
  interface "vlan3"
             ^
/var/lib/dhclient/dhclient6.leases line 17: Lease has no interface designation.
}
 ^
/var/lib/dhclient/dhclient6.leases line 17: No matching client state.
}
 ^
Listening on Socket/vlan2
Sending on   Socket/vlan2
PRC: Soliciting for leases (INIT).
XMT: Forming Solicit, 0 ms elapsed.
XMT:  X-- IA_NA 00:01:02:02
XMT:  | X-- Request renew in  +3600
XMT:  | X-- Request rebind in +5400
XMT: Solicit on vlan2, interval 1020ms.
RCV: Advertise message on vlan2 from fe80::2de:adff:feff:102.
RCV:  X-- IA_NA 00:01:02:02
RCV:  | X-- starts 1542968143
RCV:  | X-- t1 - renew  +4294967295
RCV:  | X-- t2 - rebind +4294967295
RCV:  | X-- [Options]
RCV:  | | X-- IAADDR 2001:db8:102::18
RCV:  | | | X-- Preferred lifetime 4294967295.
RCV:  | | | X-- Max lifetime 4294967295.
RCV:  X-- Server ID: 00:03:00:01:00:de:ad:ff:01:02
RCV:  Advertisement recorded.
RCV: Advertise message on vlan2 from fe80::2de:adff:feff:102.
RCV:  X-- IA_NA 00:01:02:02
RCV:  | X-- starts 1542968143
RCV:  | X-- t1 - renew  +4294967295
RCV:  | X-- t2 - rebind +4294967295
RCV:  | X-- [Options]
RCV:  | | X-- IAADDR 2001:db8:102::18
RCV:  | | | X-- Preferred lifetime 4294967295.
RCV:  | | | X-- Max lifetime 4294967295.
RCV:  X-- Server ID: 00:03:00:01:00:de:ad:ff:01:02
RCV:  Advertisement recorded.
PRC: Selecting best advertised lease.
PRC: Considering best lease.
PRC:  X-- Initial candidate 00:03:00:01:00:de:ad:ff:01:02 (s: 154, p: 0).
XMT: Forming Request, 0 ms elapsed.
XMT:  X-- IA_NA 00:01:02:02
XMT:  | X-- Requested renew  +3600
XMT:  | X-- Requested rebind +5400
XMT:  | | X-- IAADDR 2001:db8:102::18
XMT:  | | | X-- Preferred lifetime +7200
XMT:  | | | X-- Max lifetime +7500
XMT:  V IA_NA appended.
XMT: Request on vlan2, interval 940ms.
RCV: Reply message on vlan2 from fe80::2de:adff:feff:102.
RCV:  X-- IA_NA 00:01:02:02
RCV:  | X-- starts 1542968144
RCV:  | X-- t1 - renew  +4294967295
RCV:  | X-- t2 - rebind +4294967295
RCV:  | X-- [Options]
RCV:  | | X-- IAADDR 2001:db8:102::18
RCV:  | | | X-- Preferred lifetime 4294967295.
RCV:  | | | X-- Max lifetime 4294967295.
RCV:  X-- Server ID: 00:03:00:01:00:de:ad:ff:01:02
PRC: Bound to lease 00:03:00:01:00:de:ad:ff:01:02.
XMT: Forming Decline.
XMT:  X-- IA_NA 00:01:02:02
XMT:  | X-- Decline Address 2001:db8:102::18
XMT:  V IA_NA appended.
XMT: Decline on vlan2, interval 950ms.
RCV: Reply message on vlan2 from fe80::2de:adff:feff:102.
Packet received, but nothing done with it.
RCV: Reply message on vlan2 from fe80::2de:adff:feff:102.
RCV:  X-- IA_NA 00:01:02:02
RCV:  | X-- starts 1542968146
RCV:  | X-- t1 - renew  +4294967295
RCV:  | X-- t2 - rebind +4294967295
RCV:  | X-- [Options]
RCV:  | | X-- IAADDR 2001:db8:102::18
RCV:  | | | X-- Preferred lifetime 4294967295.
RCV:  | | | X-- Max lifetime 4294967295.
RCV:  X-- Server ID: 00:03:00:01:00:de:ad:ff:01:02
PRC: Soliciting for leases (INIT).
RCV: Reply message on vlan2 from fe80::2de:adff:feff:102.

Comment 16 Numan Siddique 2018-11-26 08:44:16 UTC
Hi Haidong li,

I logged in and tested again. Everything looks fine to me.

I logged into the dell-per730-19.rhts.eng.pek2.redhat.com, I deleted ns3 namespace, recreated again. Please see below.


[root@localhost ~]# ip link add link eth1  name vlan3 type vlan id 3
[root@localhost ~]# ip netns add ns3
[root@localhost ~]# ip link set vlan3 netns ns3
[root@localhost ~]# ip netns exec ns2 ip link ip netns exec ns2 ip link 
[root@localhost ~]# ip netns exec ns3 ip a
1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
7: vlan3@if3: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 00:de:ad:01:00:01 brd ff:ff:ff:ff:ff:ff link-netnsid 0
[root@localhost ~]# ip netns exec ns3 ip link set vlan3 up
[root@localhost ~]# dmesg
[254860.165248] IPv6: vlan3: IPv6 duplicate address fe80::2de:adff:fe01:1 detected!
[root@localhost ~]# dmesg
[254860.165248] IPv6: vlan3: IPv6 duplicate address fe80::2de:adff:fe01:1 detected!
[root@localhost ~]# ip netns exec ns3 ip a
1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
7: vlan3@if3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 00:de:ad:01:00:01 brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet6 fe80::2de:adff:fe01:1/64 scope link tentative dadfailed 
       valid_lft forever preferred_lft forever
[root@localhost ~]# ip netns exec ns3 ip a
1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
7: vlan3@if3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 00:00:00:01:02:03 brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet6 fe80::200:ff:fe01:203/64 scope link 
       valid_lft forever preferred_lft forever
[root@localhost ~]# ip netns exec ns3 dhclient -6 -d vlan3
Internet Systems Consortium DHCP Client 4.2.5
Copyright 2004-2013 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

/var/lib/dhclient/dhclient6.leases line 3: Unknown interface.
  interface "vlan2"
             ^
/var/lib/dhclient/dhclient6.leases line 17: Lease has no interface designation.
}
 ^
/var/lib/dhclient/dhclient6.leases line 17: No matching client state.
}
 ^
Listening on Socket/vlan3
Sending on   Socket/vlan3
PRC: Soliciting for leases (INIT).
XMT: Forming Solicit, 0 ms elapsed.
XMT:  X-- IA_NA 00:01:02:03
XMT:  | X-- Request renew in  +3600
XMT:  | X-- Request rebind in +5400
XMT: Solicit on vlan3, interval 1080ms.
RCV: Advertise message on vlan3 from fe80::2de:adff:feff:102.
RCV:  X-- IA_NA 00:01:02:03
RCV:  | X-- starts 1543221606
RCV:  | X-- t1 - renew  +4294967295
RCV:  | X-- t2 - rebind +4294967295
RCV:  | X-- [Options]
RCV:  | | X-- IAADDR 2001:db8:102::13
RCV:  | | | X-- Preferred lifetime 4294967295.
RCV:  | | | X-- Max lifetime 4294967295.
RCV:  X-- Server ID: 00:03:00:01:00:de:ad:ff:01:02
RCV:  Advertisement recorded.
RCV: Advertise message on vlan3 from fe80::2de:adff:feff:102.
RCV:  X-- IA_NA 00:01:02:03
RCV:  | X-- starts 1543221606
RCV:  | X-- t1 - renew  +4294967295
RCV:  | X-- t2 - rebind +4294967295
RCV:  | X-- [Options]
RCV:  | | X-- IAADDR 2001:db8:102::13
RCV:  | | | X-- Preferred lifetime 4294967295.
RCV:  | | | X-- Max lifetime 4294967295.
RCV:  X-- Server ID: 00:03:00:01:00:de:ad:ff:01:02
RCV:  Advertisement recorded.
PRC: Selecting best advertised lease.
PRC: Considering best lease.
PRC:  X-- Initial candidate 00:03:00:01:00:de:ad:ff:01:02 (s: 154, p: 0).
XMT: Forming Request, 0 ms elapsed.
XMT:  X-- IA_NA 00:01:02:03
XMT:  | X-- Requested renew  +3600
XMT:  | X-- Requested rebind +5400
XMT:  | | X-- IAADDR 2001:db8:102::13
XMT:  | | | X-- Preferred lifetime +7200
XMT:  | | | X-- Max lifetime +7500
XMT:  V IA_NA appended.
XMT: Request on vlan3, interval 940ms.
RCV: Reply message on vlan3 from fe80::2de:adff:feff:102.
RCV:  X-- IA_NA 00:01:02:03
RCV:  | X-- starts 1543221607
RCV:  | X-- t1 - renew  +4294967295
RCV:  | X-- t2 - rebind +4294967295
RCV:  | X-- [Options]
RCV:  | | X-- IAADDR 2001:db8:102::13
RCV:  | | | X-- Preferred lifetime 4294967295.
RCV:  | | | X-- Max lifetime 4294967295.
RCV:  X-- Server ID: 00:03:00:01:00:de:ad:ff:01:02
PRC: Bound to lease 00:03:00:01:00:de:ad:ff:01:02.
RCV: Reply message on vlan3 from fe80::2de:adff:feff:102.
RCV: Input packets are ignored once bound.

[root@localhost ~]# ip netns exec ns3 ip a
1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
7: vlan3@if3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 00:00:00:01:02:03 brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet6 2001:db8:102::13/64 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::200:ff:fe01:203/64 scope link 
       valid_lft forever preferred_lft forever
[root@localhost ~]# ip netns exec ns3 ping6 -I vlan3 2001:db8:102::12
PING 2001:db8:102::12(2001:db8:102::12) from 2001:db8:102::13 vlan3: 56 data bytes
64 bytes from 2001:db8:102::12: icmp_seq=1 ttl=64 time=1.89 ms
64 bytes from 2001:db8:102::12: icmp_seq=2 ttl=64 time=0.520 ms

--- 2001:db8:102::12 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 0.520/1.206/1.893/0.687 ms

*****

What is your concern ?
Is the below dmesg concern for you ?

[root@localhost ~]# dmesg
[254860.165248] IPv6: vlan3: IPv6 duplicate address fe80::2de:adff:fe01:1 detected!

If so, you would see it because vlan3 and eth1 at this time have same mac address. Once you change the mac address of vlan3 to the correct one, you wouldn't see the "duplicated address" message.

If you still see the issue can you please share me the commands which I can try it out myself.

Thanks
Numan

Comment 17 haidong li 2018-12-04 09:03:10 UTC
I have checked again,the issue is verified.
Change the status to verified according to comment16.

Comment 24 errata-xmlrpc 2019-01-07 08:51:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0029


Note You need to log in before you can comment on or make changes to this bug.